Apache StreamPipes, Apache StreamPipes: Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) in Recovery Token Generation
Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) vulnerability in Apache StreamPipes user self-registration and password recovery mechanism. This allows an attacker to guess the recovery token in a reasonable time and thereby to take over the attacked user's account. This issue affects Apache StreamPipes: from 0.69.0 through 0.93.0. Users are recommended to upgrade to version 0.95.0, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-29868
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 21:18 UTC · Revision 1
Source evidence
Apache StreamPipes, Apache StreamPipes: Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) in Recovery Token Generation
core-osv · Original sourcePublished 24 Jun 2024, 09:59 UTC
Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) vulnerability in Apache StreamPipes user self-registration and password recovery mechanism. This allows an attacker to guess the recovery token in a reasonable time and thereby to take over the attacked user's account. This issue affects Apache StreamPipes: from 0.69.0 through 0.93.0. Users are recommended to upgrade to version 0.95.0, which fixes the issue.
osv:CVE-2024-29868
Complete source record
{
"id": "e4fdd727f3c93a18e4dca66024c3653d610bb1a9f9e661312a59dfad038243b1",
"url": "https://osv.dev/vulnerability/CVE-2024-29868",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache StreamPipes, Apache StreamPipes: Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) in Recovery Token Generation",
"summary": "Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) vulnerability in Apache StreamPipes user self-registration and password recovery mechanism. This allows an attacker to guess the recovery token in a reasonable time and thereby to take over the attacked user's account. This issue affects Apache StreamPipes: from 0.69.0 through 0.93.0. Users are recommended to upgrade to version 0.95.0, which fixes the issue.",
"evidence": "osv:CVE-2024-29868",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2024-29868",
"aliases": [
"CVE-2024-29868",
"GHSA-cf3q-vg8w-mw84"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/streampipes",
"type": "GIT",
"events": [
{
"introduced": "952c51b2d6f76648a349167e97be2b8c30783dc5"
},
{
"last_affected": "39d9986f41b93dbe9060c38b05ccf74e8e349ff6"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:streampipes:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0.69.0"
},
{
"last_affected": "0.93.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-29868.json"
}
}
],
"modified": "2026-10-28T02:30:23.563075209Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/29xxx/CVE-2024-29868.json",
"https://lists.apache.org/thread/g7t7zctvq2fysrw1x17flnc12592nhx7",
"https://nvd.nist.gov/vuln/detail/CVE-2024-29868"
],
"provider_metadata": {
"cwe_ids": [
"CWE-338"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "0.69.0"
},
{
"last_affected": "0.93.0"
},
{
"introduced": "0.69.0"
},
{
"last_affected": "0.93.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/29xxx/CVE-2024-29868.json"
}
},
"related_cves": [
{
"value": "CVE-2024-29868",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 490188,
"published_at": "2024-06-24T09:59:39.941+00:00"
}