HighFix available
gstreamer0.10, gstreamer1.0 — security advisory
The gst_date_time_new_from_iso8601_string function in gst/gstdatetime.c in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a malformed datetime string.
- Products
- gstreamer0.10, gstreamer1.0
- Affected versions
- 0.10.36-1.5ubuntu1, 1.6.0-1, 1.6.1-1, 1.6.2-1, 1.7.1-1, 1.7.2-1, 1.7.90-1, 1.7.91-1, 1.8.0-1, 1.8.1-1~ubuntu1, 1.8.2-1~ubuntu1, 1.8.3-1~ubuntu0.1
- Fixed versions
- 1.8.3-1~ubuntu0.1+esm1
- CVEs
- CVE-2017-5838
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 09:08 UTC · Revision 1
Source evidence
The gst_date_time_new_from_iso8601_string function in gst/gstdatetime.c in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a malformed datetime string.
osv:UBUNTU-CVE-2017-5838
gstreamer1.0
Fixed versions: 1.8.3-1~ubuntu0.1+esm1
gstreamer0.10
Fixed versions: Not specified
Complete source record
{
"id": "0f8868aac8babedbe0d14c3181dfeccb7f0589d8696d159310aa937812531ab6",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2017-5838",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2017-5838",
"summary": "The gst_date_time_new_from_iso8601_string function in gst/gstdatetime.c in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (out-of-bounds heap read) via a malformed datetime string.",
"evidence": "osv:UBUNTU-CVE-2017-5838",
"products": [
{
"name": {
"value": "gstreamer1.0",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.8.3-1~ubuntu0.1+esm1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "1.6.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.6.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.6.2-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.7.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.7.2-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.7.90-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.7.91-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.1-1~ubuntu1",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.2-1~ubuntu1",
"evidence": "/affected/0/versions"
},
{
"value": "1.8.3-1~ubuntu0.1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "gstreamer0.10",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "0.10.36-1.5ubuntu1",
"evidence": "/affected/1/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "UBUNTU-CVE-2017-5838",
"aliases": [
"UBUNTU-CVE-2017-5838"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
},
{
"type": "Ubuntu",
"score": "low"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.8.3-1~ubuntu0.1+esm1"
}
]
}
],
"package": {
"name": "gstreamer1.0",
"purl": "pkg:deb/ubuntu/gstreamer1.0?arch=source&distro=esm-infra%2Fxenial",
"ecosystem": "Ubuntu:Pro:16.04:LTS"
},
"versions": [
"1.6.0-1",
"1.6.1-1",
"1.6.2-1",
"1.7.1-1",
"1.7.2-1",
"1.7.90-1",
"1.7.91-1",
"1.8.0-1",
"1.8.1-1~ubuntu1",
"1.8.2-1~ubuntu1",
"1.8.3-1~ubuntu0.1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2017/UBUNTU-CVE-2017-5838.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "gir1.2-gstreamer-1.0",
"binary_version": "1.8.3-1~ubuntu0.1+esm1"
},
{
"binary_name": "gstreamer1.0-tools",
"binary_version": "1.8.3-1~ubuntu0.1+esm1"
},
{
"binary_name": "libgstreamer1.0-0",
"binary_version": "1.8.3-1~ubuntu0.1+esm1"
}
],
"availability": "Available with Ubuntu Pro (Infra-only): https://ubuntu.com/pro"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "gstreamer0.10",
"purl": "pkg:deb/ubuntu/gstreamer0.10?arch=source&distro=xenial",
"ecosystem": "Ubuntu:16.04:LTS"
},
"versions": [
"0.10.36-1.5ubuntu1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2017/UBUNTU-CVE-2017-5838.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "gir1.2-gstreamer-0.10",
"binary_version": "0.10.36-1.5ubuntu1"
},
{
"binary_name": "gstreamer-tools",
"binary_version": "0.10.36-1.5ubuntu1"
},
{
"binary_name": "gstreamer0.10-tools",
"binary_version": "0.10.36-1.5ubuntu1"
},
{
"binary_name": "libgstreamer0.10-0",
"binary_version": "0.10.36-1.5ubuntu1"
}
]
}
}
],
"modified": "2026-10-08T12:50:04.452014512Z",
"provider": "osv",
"upstream": [
"CVE-2017-5838"
],
"references": [
"https://ubuntu.com/security/CVE-2017-5838",
"https://ubuntu.com/security/notices/USN-6291-1",
"https://www.cve.org/CVERecord?id=CVE-2017-5838"
]
},
"related_cves": [
{
"value": "CVE-2017-5838",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 99521,
"published_at": "2017-02-09T15:59:00+00:00"
}