HighFix available
fort-validator — security advisory
FORT Validator versions prior to 1.5.2 will crash if an RPKI CA publishes an X.509 EE certificate. This will lead to RTR clients such as BGP routers to lose access to the RPKI VRP data set, effectively disabling Route Origin Validation.
- Products
- fort-validator
- Affected versions
- Not specified
- Fixed versions
- 1.5.2-1
- CVEs
- CVE-2021-43114
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 01:21 UTC · Revision 1
Source evidence
FORT Validator versions prior to 1.5.2 will crash if an RPKI CA publishes an X.509 EE certificate. This will lead to RTR clients such as BGP routers to lose access to the RPKI VRP data set, effectively disabling Route Origin Validation.
osv:DEBIAN-CVE-2021-43114
fort-validator
Fixed versions: 1.5.2-1
fort-validator
Fixed versions: 1.5.2-1
fort-validator
Fixed versions: 1.5.2-1
Complete source record
{
"id": "2b2be4ec43b3df95a37459950e8e7302eabae2ab4aab5e56903185d671834210",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-43114",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2021-43114",
"summary": "FORT Validator versions prior to 1.5.2 will crash if an RPKI CA publishes an X.509 EE certificate. This will lead to RTR clients such as BGP routers to lose access to the RPKI VRP data set, effectively disabling Route Origin Validation.",
"evidence": "osv:DEBIAN-CVE-2021-43114",
"products": [
{
"name": {
"value": "fort-validator",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.5.2-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "fort-validator",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.5.2-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "fort-validator",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.5.2-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2021-43114",
"aliases": [
"DEBIAN-CVE-2021-43114"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.5.2-1"
}
]
}
],
"package": {
"name": "fort-validator",
"purl": "pkg:deb/debian/fort-validator?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-43114.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.5.2-1"
}
]
}
],
"package": {
"name": "fort-validator",
"purl": "pkg:deb/debian/fort-validator?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-43114.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.5.2-1"
}
]
}
],
"package": {
"name": "fort-validator",
"purl": "pkg:deb/debian/fort-validator?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-43114.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:04:39.014662035Z",
"provider": "osv",
"upstream": [
"CVE-2021-43114"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2021-43114"
]
},
"related_cves": [
{
"value": "CVE-2021-43114",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 423607,
"published_at": "2021-11-09T13:15:08.447+00:00"
}