Skip to content
Heist/ feed
Back to feed
CriticalFix available

Apache Tomcat: console manipulation via escape sequences in log messages

Type: advisorySources: OSV

Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems. This issue affects Apache Tomcat: from 11.0.0 through 11.0.10, from 10.1.0 through 10.1.44, from 9.0.40 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.

Products
tomcat
Affected versions
Not specified
Fixed versions
10.1.45, 11.0.11, 9.0.109
CVEs
CVE-2025-55754
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 19:55 UTC · Revision 1

Source evidence

Apache Tomcat: console manipulation via escape sequences in log messages

core-osv · Original source

Published 6 Nov 2025, 13:00 UTC

Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems. This issue affects Apache Tomcat: from 11.0.0 through 11.0.10, from 10.1.0 through 10.1.44, from 9.0.40 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.

osv:BIT-tomcat-2025-55754

tomcat

Fixed versions: 9.0.109, 10.1.45, 11.0.11

Complete source record
{
  "id": "bbd31266a81ad86ea2ccc08c9fb58fe68ea799fb37b7f6a97a98288ce58494b0",
  "url": "https://osv.dev/vulnerability/BIT-tomcat-2025-55754",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache Tomcat: console manipulation via escape sequences in log messages",
    "summary": "Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems. This issue affects Apache Tomcat: from 11.0.0 through 11.0.10, from 10.1.0 through 10.1.44, from 9.0.40 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.",
    "evidence": "osv:BIT-tomcat-2025-55754",
    "products": [
      {
        "name": {
          "value": "tomcat",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "9.0.109",
            "evidence": "/affected/0/ranges"
          },
          {
            "value": "10.1.45",
            "evidence": "/affected/0/ranges"
          },
          {
            "value": "11.0.11",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "BIT-tomcat-2025-55754",
      "aliases": [
        "BIT-tomcat-2025-55754",
        "CVE-2025-55754",
        "GHSA-vfww-5hm6-hx2j"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "9.0.109"
                },
                {
                  "introduced": "10.0.0"
                },
                {
                  "fixed": "10.1.45"
                },
                {
                  "introduced": "11.0.0"
                },
                {
                  "fixed": "11.0.11"
                }
              ]
            }
          ],
          "package": {
            "name": "tomcat",
            "purl": "pkg:bitnami/tomcat",
            "ecosystem": "Bitnami"
          },
          "severity": [
            {
              "type": "CVSS_V3",
              "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H"
            }
          ],
          "database_specific": {
            "source": "https://github.com/bitnami/vulndb/tree/main/data/tomcat/BIT-tomcat-2025-55754.json"
          }
        }
      ],
      "modified": "2026-10-16T09:45:32.922296779Z",
      "provider": "osv",
      "references": [
        "https://lists.apache.org/thread/j7w54hqbkfcn0xb9xy0wnx8w5nymcbqd",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-55754"
      ],
      "provider_metadata": {
        "cpes": [
          "cpe:2.3:a:apache:tomcat:*:*:*:*:*:maven:*:*"
        ],
        "severity": "Critical"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-55754",
        "evidence": "/aliases"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/database_specific/severity"
  },
  "source_id": "core-osv",
  "document_id": 338506,
  "published_at": "2025-11-06T13:00:33.572+00:00"
}