MediumFix available
gst-plugins-ugly0.10, gst-plugins-ugly1.0 — security advisory
The gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors related to the number of languages in a video file.
- Products
- gst-plugins-ugly0.10, gst-plugins-ugly1.0
- Affected versions
- 0.10.19-2, 0.10.19-2ubuntu1, 0.10.19-2ubuntu2, 0.10.19-2ubuntu3, 0.10.19-2ubuntu5, 1.6.0-1ubuntu1, 1.6.1-1ubuntu1, 1.6.2-1ubuntu1, 1.7.1-1ubuntu1, 1.7.2-1ubuntu1, 1.7.90-1ubuntu1, 1.7.91-1ubuntu1, 1.8.0-1ubuntu1, 1.8.1-1ubuntu0.1, 1.8.2-1ubuntu0.1, 1.8.3-1ubuntu0.1, 1.8.3-1ubuntu0.1+esm1, 1.8.3-1ubuntu0.1+esm2
- Fixed versions
- 0.10.19-2+deb7u1ubuntu0.1
- CVEs
- CVE-2017-5846
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 09:08 UTC · Revision 1
Source evidence
The gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors related to the number of languages in a video file.
osv:UBUNTU-CVE-2017-5846
gst-plugins-ugly0.10
Fixed versions: 0.10.19-2+deb7u1ubuntu0.1
gst-plugins-ugly1.0
Fixed versions: Not specified
Complete source record
{
"id": "0035e82c3167146b4d214ca46614d1eeaead82e5f7e53c639b4a37c23e7115de",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2017-5846",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2017-5846",
"summary": "The gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors related to the number of languages in a video file.",
"evidence": "osv:UBUNTU-CVE-2017-5846",
"products": [
{
"name": {
"value": "gst-plugins-ugly0.10",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.10.19-2+deb7u1ubuntu0.1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "0.10.19-2",
"evidence": "/affected/0/versions"
},
{
"value": "0.10.19-2ubuntu1",
"evidence": "/affected/0/versions"
},
{
"value": "0.10.19-2ubuntu2",
"evidence": "/affected/0/versions"
},
{
"value": "0.10.19-2ubuntu3",
"evidence": "/affected/0/versions"
},
{
"value": "0.10.19-2ubuntu5",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "gst-plugins-ugly1.0",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "1.6.0-1ubuntu1",
"evidence": "/affected/1/versions"
},
{
"value": "1.6.1-1ubuntu1",
"evidence": "/affected/1/versions"
},
{
"value": "1.6.2-1ubuntu1",
"evidence": "/affected/1/versions"
},
{
"value": "1.7.1-1ubuntu1",
"evidence": "/affected/1/versions"
},
{
"value": "1.7.2-1ubuntu1",
"evidence": "/affected/1/versions"
},
{
"value": "1.7.90-1ubuntu1",
"evidence": "/affected/1/versions"
},
{
"value": "1.7.91-1ubuntu1",
"evidence": "/affected/1/versions"
},
{
"value": "1.8.0-1ubuntu1",
"evidence": "/affected/1/versions"
},
{
"value": "1.8.1-1ubuntu0.1",
"evidence": "/affected/1/versions"
},
{
"value": "1.8.2-1ubuntu0.1",
"evidence": "/affected/1/versions"
},
{
"value": "1.8.3-1ubuntu0.1",
"evidence": "/affected/1/versions"
},
{
"value": "1.8.3-1ubuntu0.1+esm1",
"evidence": "/affected/1/versions"
},
{
"value": "1.8.3-1ubuntu0.1+esm2",
"evidence": "/affected/1/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "UBUNTU-CVE-2017-5846",
"aliases": [
"UBUNTU-CVE-2017-5846"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H"
},
{
"type": "Ubuntu",
"score": "low"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.10.19-2+deb7u1ubuntu0.1"
}
]
}
],
"package": {
"name": "gst-plugins-ugly0.10",
"purl": "pkg:deb/ubuntu/gst-plugins-ugly0.10?arch=source&distro=trusty",
"ecosystem": "Ubuntu:14.04:LTS"
},
"versions": [
"0.10.19-2",
"0.10.19-2ubuntu1",
"0.10.19-2ubuntu2",
"0.10.19-2ubuntu3",
"0.10.19-2ubuntu5"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2017/UBUNTU-CVE-2017-5846.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "gstreamer0.10-plugins-ugly",
"binary_version": "0.10.19-2+deb7u1ubuntu0.1"
}
],
"availability": "No subscription required"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "gst-plugins-ugly1.0",
"purl": "pkg:deb/ubuntu/gst-plugins-ugly1.0?arch=source&distro=esm-apps-legacy%2Fxenial",
"ecosystem": "Ubuntu:Pro:16.04:LTS"
},
"versions": [
"1.6.0-1ubuntu1",
"1.6.1-1ubuntu1",
"1.6.2-1ubuntu1",
"1.7.1-1ubuntu1",
"1.7.2-1ubuntu1",
"1.7.90-1ubuntu1",
"1.7.91-1ubuntu1",
"1.8.0-1ubuntu1",
"1.8.1-1ubuntu0.1",
"1.8.2-1ubuntu0.1",
"1.8.3-1ubuntu0.1",
"1.8.3-1ubuntu0.1+esm1",
"1.8.3-1ubuntu0.1+esm2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2017/UBUNTU-CVE-2017-5846.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "gstreamer1.0-plugins-ugly",
"binary_version": "1.8.3-1ubuntu0.1+esm2"
},
{
"binary_name": "gstreamer1.0-plugins-ugly-amr",
"binary_version": "1.8.3-1ubuntu0.1+esm2"
}
]
}
}
],
"modified": "2026-10-08T12:50:14.970648471Z",
"provider": "osv",
"upstream": [
"CVE-2017-5846"
],
"references": [
"https://ubuntu.com/security/CVE-2017-5846",
"https://www.cve.org/CVERecord?id=CVE-2017-5846"
]
},
"related_cves": [
{
"value": "CVE-2017-5846",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 99527,
"published_at": "2017-02-09T15:59:00+00:00"
}