Skip to content
Heist/ feed
Back to feed
High

rust-libp2p-identity — security advisory

Type: advisorySources: OSVAdvisory ID: UBUNTU-CVE-2026-61544

libp2p-rust is the official Rust language implementation of the libp2p networking stack. Prior to 0.13.1, libp2p-quic could panic during an inbound QUIC handshake when a remote peer presented a valid short-lived libp2p TLS certificate and delayed the final TLS 1.3 handshake fragment until after the certificate expired. In the Quinn post-handshake upgrade path, transports/quic/src/connection/connecting.rs called libp2p_tls::certificate::parse a second time in remote_peer_id and used expect on the result. The repeated wall-clock validity check could reject the now-expired certificate, causing the expect call to terminate any application exposing an affected libp2p-quic listener. This vulnerability is fixed in 0.13.1.

Products
rust-libp2p-identity
Affected versions
0.2.10+20250205+ds-1, 0.2.12+20250805+ds-2, 0.2.13+ds-1
Fixed versions
Not specified
CVEs
CVE-2026-61544
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 02:49 UTC · Revision 1

Source evidence

UBUNTU-CVE-2026-61544

core-osv · Original source

Published 15 Sept 2026, 20:17 UTC

libp2p-rust is the official Rust language implementation of the libp2p networking stack. Prior to 0.13.1, libp2p-quic could panic during an inbound QUIC handshake when a remote peer presented a valid short-lived libp2p TLS certificate and delayed the final TLS 1.3 handshake fragment until after the certificate expired. In the Quinn post-handshake upgrade path, transports/quic/src/connection/connecting.rs called libp2p_tls::certificate::parse a second time in remote_peer_id and used expect on the result. The repeated wall-clock validity check could reject the now-expired certificate, causing the expect call to terminate any application exposing an affected libp2p-quic listener. This vulnerability is fixed in 0.13.1.

osv:UBUNTU-CVE-2026-61544

rust-libp2p-identity

Fixed versions: Not specified

rust-libp2p-identity

Fixed versions: Not specified

Complete source record
{
  "id": "e0a24ea6e7ee596cc424cb5cc4248642ba44c2e35f9878b882d6ce0006ac7864",
  "url": "https://osv.dev/vulnerability/UBUNTU-CVE-2026-61544",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "UBUNTU-CVE-2026-61544",
    "summary": "libp2p-rust is the official Rust language implementation of the libp2p networking stack. Prior to 0.13.1, libp2p-quic could panic during an inbound QUIC handshake when a remote peer presented a valid short-lived libp2p TLS certificate and delayed the final TLS 1.3 handshake fragment until after the certificate expired. In the Quinn post-handshake upgrade path, transports/quic/src/connection/connecting.rs called libp2p_tls::certificate::parse a second time in remote_peer_id and used expect on the result. The repeated wall-clock validity check could reject the now-expired certificate, causing the expect call to terminate any application exposing an affected libp2p-quic listener. This vulnerability is fixed in 0.13.1.",
    "evidence": "osv:UBUNTU-CVE-2026-61544",
    "products": [
      {
        "name": {
          "value": "rust-libp2p-identity",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [],
        "affected_versions": [
          {
            "value": "0.2.13+ds-1",
            "evidence": "/affected/0/versions"
          }
        ]
      },
      {
        "name": {
          "value": "rust-libp2p-identity",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [],
        "affected_versions": [
          {
            "value": "0.2.10+20250205+ds-1",
            "evidence": "/affected/1/versions"
          },
          {
            "value": "0.2.12+20250805+ds-2",
            "evidence": "/affected/1/versions"
          },
          {
            "value": "0.2.13+ds-1",
            "evidence": "/affected/1/versions"
          }
        ]
      }
    ],
    "severity": "high",
    "structured": {
      "id": "UBUNTU-CVE-2026-61544",
      "aliases": [
        "UBUNTU-CVE-2026-61544"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N"
        },
        {
          "type": "Ubuntu",
          "score": "medium"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                }
              ]
            }
          ],
          "package": {
            "name": "rust-libp2p-identity",
            "purl": "pkg:deb/ubuntu/rust-libp2p-identity?arch=source&distro=stonking",
            "ecosystem": "Ubuntu:26.10"
          },
          "versions": [
            "0.2.13+ds-1"
          ],
          "database_specific": {
            "source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-61544.json"
          },
          "ecosystem_specific": {
            "binaries": [
              {
                "binary_name": "librust-libp2p-identity-dev",
                "binary_version": "0.2.13+ds-1"
              }
            ]
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                }
              ]
            }
          ],
          "package": {
            "name": "rust-libp2p-identity",
            "purl": "pkg:deb/ubuntu/rust-libp2p-identity?arch=source&distro=resolute",
            "ecosystem": "Ubuntu:26.04:LTS"
          },
          "versions": [
            "0.2.10+20250205+ds-1",
            "0.2.12+20250805+ds-2",
            "0.2.13+ds-1"
          ],
          "database_specific": {
            "source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-61544.json"
          },
          "ecosystem_specific": {
            "binaries": [
              {
                "binary_name": "librust-libp2p-identity-dev",
                "binary_version": "0.2.13+ds-1"
              }
            ]
          }
        }
      ],
      "modified": "2026-10-17T12:59:14.916940546Z",
      "provider": "osv",
      "upstream": [
        "CVE-2026-61544"
      ],
      "references": [
        "https://ubuntu.com/security/CVE-2026-61544",
        "https://www.cve.org/CVERecord?id=CVE-2026-61544",
        "https://github.com/libp2p/rust-libp2p/commit/212f3774af048e2cecfb2e6b1e08477685e52b22",
        "https://github.com/libp2p/rust-libp2p/commit/e8f35e12c2418b04df6e9cdf036005e8aee3c7a2",
        "https://github.com/libp2p/rust-libp2p/pull/6525",
        "https://github.com/libp2p/rust-libp2p/security/advisories/GHSA-5hq8-qhww-jm7q"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2026-61544",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 359538,
  "published_at": "2026-09-15T20:17:00+00:00"
}