node-prismjs — security advisory
Prism is vulnerable to Cross-Site Scripting. The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the _Previewers_ plugin (>=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0). This problem is fixed in version 1.21.0. To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.
- Products
- node-prismjs
- Affected versions
- Not specified
- Fixed versions
- 1.11.0+dfsg-4
- CVEs
- CVE-2020-15138
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 13:25 UTC · Revision 1
Source evidence
Prism is vulnerable to Cross-Site Scripting. The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the _Previewers_ plugin (>=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0). This problem is fixed in version 1.21.0. To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.
osv:DEBIAN-CVE-2020-15138
node-prismjs
Fixed versions: 1.11.0+dfsg-4
node-prismjs
Fixed versions: 1.11.0+dfsg-4
node-prismjs
Fixed versions: 1.11.0+dfsg-4
Complete source record
{
"id": "4f70992d2df1b0fb371c7278330e140b392da683c1c669576c40a3332a18ab53",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2020-15138",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2020-15138",
"summary": "Prism is vulnerable to Cross-Site Scripting. The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the _Previewers_ plugin (>=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0). This problem is fixed in version 1.21.0. To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.",
"evidence": "osv:DEBIAN-CVE-2020-15138",
"products": [
{
"name": {
"value": "node-prismjs",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.11.0+dfsg-4",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "node-prismjs",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.11.0+dfsg-4",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "node-prismjs",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.11.0+dfsg-4",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2020-15138",
"aliases": [
"DEBIAN-CVE-2020-15138"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.11.0+dfsg-4"
}
]
}
],
"package": {
"name": "node-prismjs",
"purl": "pkg:deb/debian/node-prismjs?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2020-15138.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.11.0+dfsg-4"
}
]
}
],
"package": {
"name": "node-prismjs",
"purl": "pkg:deb/debian/node-prismjs?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2020-15138.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.11.0+dfsg-4"
}
]
}
],
"package": {
"name": "node-prismjs",
"purl": "pkg:deb/debian/node-prismjs?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2020-15138.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T12:02:26.583296767Z",
"provider": "osv",
"upstream": [
"CVE-2020-15138"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2020-15138"
]
},
"related_cves": [
{
"value": "CVE-2020-15138",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 452201,
"published_at": "2020-08-07T17:15:10.45+00:00"
}