Skip to content
Heist/ feed
Back to feed
UnratedFix available

phpmyadmin — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2011-2505

libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the SESSION superglobal array via a crafted request, related to a "remote variable manipulation vulnerability."

Products
phpmyadmin
Affected versions
Not specified
Fixed versions
4:3.4.3.1-1
CVEs
CVE-2011-2505
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 23:14 UTC · Revision 1

Source evidence

DEBIAN-CVE-2011-2505

core-osv · Original source

Published 14 Jul 2011, 23:55 UTC

libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the SESSION superglobal array via a crafted request, related to a "remote variable manipulation vulnerability."

osv:DEBIAN-CVE-2011-2505

phpmyadmin

Fixed versions: 4:3.4.3.1-1

phpmyadmin

Fixed versions: 4:3.4.3.1-1

phpmyadmin

Fixed versions: 4:3.4.3.1-1

Complete source record
{
  "id": "cd882eb1e857f0e201e53d6ebe03c9d57d98382dc657a394517320c8df68922c",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2011-2505",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2011-2505",
    "summary": "libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the SESSION superglobal array via a crafted request, related to a \"remote variable manipulation vulnerability.\"",
    "evidence": "osv:DEBIAN-CVE-2011-2505",
    "products": [
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:3.4.3.1-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:3.4.3.1-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:3.4.3.1-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "unknown",
    "structured": {
      "id": "DEBIAN-CVE-2011-2505",
      "aliases": [
        "DEBIAN-CVE-2011-2505"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:3.4.3.1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-2505.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:3.4.3.1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-2505.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:3.4.3.1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2011-2505.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T17:47:38.529922768Z",
      "provider": "osv",
      "upstream": [
        "CVE-2011-2505"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2011-2505"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2011-2505",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 418090,
  "published_at": "2011-07-14T23:55:04.833+00:00"
}