Skip to content
Heist/ feed
Back to feed
UnratedFix available

phpmyadmin — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2014-4987

server_user_groups.php in phpMyAdmin 4.1.x before 4.1.14.2 and 4.2.x before 4.2.6 allows remote authenticated users to bypass intended access restrictions and read the MySQL user list via a viewUsers request.

Products
phpmyadmin
Affected versions
Not specified
Fixed versions
4:4.2.6-1
CVEs
CVE-2014-4987
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 21:47 UTC · Revision 1

Source evidence

DEBIAN-CVE-2014-4987

core-osv · Original source

Published 20 Jul 2014, 11:12 UTC

server_user_groups.php in phpMyAdmin 4.1.x before 4.1.14.2 and 4.2.x before 4.2.6 allows remote authenticated users to bypass intended access restrictions and read the MySQL user list via a viewUsers request.

osv:DEBIAN-CVE-2014-4987

phpmyadmin

Fixed versions: 4:4.2.6-1

phpmyadmin

Fixed versions: 4:4.2.6-1

phpmyadmin

Fixed versions: 4:4.2.6-1

Complete source record
{
  "id": "9b61aa50d0168324be6ffaf2090280601a7f21acf024e20144d295ac8c148fd7",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-4987",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2014-4987",
    "summary": "server_user_groups.php in phpMyAdmin 4.1.x before 4.1.14.2 and 4.2.x before 4.2.6 allows remote authenticated users to bypass intended access restrictions and read the MySQL user list via a viewUsers request.",
    "evidence": "osv:DEBIAN-CVE-2014-4987",
    "products": [
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:4.2.6-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:4.2.6-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:4.2.6-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "unknown",
    "structured": {
      "id": "DEBIAN-CVE-2014-4987",
      "aliases": [
        "DEBIAN-CVE-2014-4987"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:4.2.6-1"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4987.json"
          },
          "ecosystem_specific": {
            "urgency": "low"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:4.2.6-1"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4987.json"
          },
          "ecosystem_specific": {
            "urgency": "low"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:4.2.6-1"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4987.json"
          },
          "ecosystem_specific": {
            "urgency": "low"
          }
        }
      ],
      "modified": "2026-10-23T15:47:38.182869722Z",
      "provider": "osv",
      "upstream": [
        "CVE-2014-4987"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2014-4987"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2014-4987",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 414447,
  "published_at": "2014-07-20T11:12:51.29+00:00"
}