Skip to content
Heist/ feed
Back to feed
Medium

Security issue in fhir-works-on-aws-authz-smart

Type: advisorySources: OSV

fhir-works-on-aws-authz-smart is an implementation of the authorization interface from the FHIR Works interface. Versions 3.1.1 and 3.1.2 are subject to Exposure of Sensitive Information to an Unauthorized Actor. This issue allows a client of the API to retrieve more information than the client’s OAuth scope permits when making “search-type” requests. This issue would not allow a client to retrieve information about individuals other than those the client was already authorized to access. Users of fhir-works-on-aws-authz-smart 3.1.1 or 3.1.2 should upgrade to version 3.1.3 or higher immediately. Versions 3.1.0 and below are unaffected. There is no workaround for this issue.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-39230
Confirmed fixed CVEs
Not specified
Updated in this feed
2 Nov 2026, 23:40 UTC · Revision 1

Source evidence

Security issue in fhir-works-on-aws-authz-smart

core-osv · Original source

Published 23 Sept 2022, 07:10 UTC

fhir-works-on-aws-authz-smart is an implementation of the authorization interface from the FHIR Works interface. Versions 3.1.1 and 3.1.2 are subject to Exposure of Sensitive Information to an Unauthorized Actor. This issue allows a client of the API to retrieve more information than the client’s OAuth scope permits when making “search-type” requests. This issue would not allow a client to retrieve information about individuals other than those the client was already authorized to access. Users of fhir-works-on-aws-authz-smart 3.1.1 or 3.1.2 should upgrade to version 3.1.3 or higher immediately. Versions 3.1.0 and below are unaffected. There is no workaround for this issue.

osv:CVE-2022-39230
Complete source record
{
  "id": "c8fe784f518a77ea19732c37c036a481f60d4107704bfa5c2c074119ca445a29",
  "url": "https://osv.dev/vulnerability/CVE-2022-39230",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Security issue in fhir-works-on-aws-authz-smart",
    "summary": "fhir-works-on-aws-authz-smart is an implementation of the authorization interface from the FHIR Works interface. Versions 3.1.1 and 3.1.2 are subject to Exposure of Sensitive Information to an Unauthorized Actor. This issue allows a client of the API to retrieve more information than the client’s OAuth scope permits when making “search-type” requests. This issue would not allow a client to retrieve information about individuals other than those the client was already authorized to access. Users of fhir-works-on-aws-authz-smart 3.1.1 or 3.1.2 should upgrade to version 3.1.3 or higher immediately. Versions 3.1.0 and below are unaffected. There is no workaround for this issue.",
    "evidence": "osv:CVE-2022-39230",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2022-39230",
      "aliases": [
        "CVE-2022-39230",
        "GHSA-vv7x-7w4m-q72f"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/awslabs/fhir-works-on-aws-authz-smart",
              "type": "GIT",
              "events": [
                {
                  "introduced": "96564791ca35f4ca96e1ae19b8184a18aa0bf449"
                },
                {
                  "fixed": "64f6a298a53ef9a9cc8417ee2d7d22632f79763d"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "3.1.0"
                      },
                      {
                        "fixed": "3.1.3"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "cpe": "cpe:2.3:a:amazon:fhir-works-on-aws-authz-smart:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "3.1.0"
                      },
                      {
                        "fixed": "3.1.3"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v3.1.2",
            "v3.1.1",
            "v3.1.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-39230.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:24.535852975Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39230.json",
        "https://github.com/awslabs/fhir-works-on-aws-authz-smart/security/advisories/GHSA-vv7x-7w4m-q72f",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-39230"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-200"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39230.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-39230",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 490936,
  "published_at": "2022-09-23T07:10:08+00:00"
}