WP Last Modified Info <= 1.9.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via lmt-post-modified-info Shortcode
The WP Last Modified Info plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘template’ attribute of the lmt-post-modified-info shortcode in all versions up to, and including, 1.9.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-6864
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 18:04 UTC · Revision 1
Source evidence
WP Last Modified Info <= 1.9.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via lmt-post-modified-info Shortcode
core-osv · Original sourcePublished 20 Aug 2024, 04:28 UTC
The WP Last Modified Info plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘template’ attribute of the lmt-post-modified-info shortcode in all versions up to, and including, 1.9.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
osv:CVE-2024-6864
Complete source record
{
"id": "81393cb928942a663ec3e8aa56418336bc4ccf0fa7d4a43678540d45147bcb50",
"url": "https://osv.dev/vulnerability/CVE-2024-6864",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WP Last Modified Info <= 1.9.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via lmt-post-modified-info Shortcode",
"summary": "The WP Last Modified Info plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘template’ attribute of the lmt-post-modified-info shortcode in all versions up to, and including, 1.9.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
"evidence": "osv:CVE-2024-6864",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-6864",
"aliases": [
"CVE-2024-6864"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/iamsayan/wp-last-modified-info",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "13f1f61c01e9a1a97c93fa76c25b72b046447611"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:sayandatta:wp_last_modified_info:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.9.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v1.9.0",
"v1.8.9",
"v1.8.8",
"v1.8.7",
"v1.8.6",
"v1.8.5",
"v1.8.4",
"v1.8.3",
"v1.8.2",
"v1.8.1",
"v1.8.0",
"v1.7.1",
"v1.7.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-6864.json"
}
}
],
"modified": "2026-10-28T02:30:30.905860616Z",
"provider": "osv",
"references": [
"https://plugins.trac.wordpress.org/browser/wp-last-modified-info/trunk/inc/Core/Frontend/PostView.php#L205",
"https://plugins.trac.wordpress.org/changeset/3137253/",
"https://plugins.trac.wordpress.org/changeset/3137253/#file23",
"https://wordpress.org/plugins/wp-last-modified-info/#developers",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/87368d85-04d4-42e6-9ba6-2a1fc3b945a8?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/6xxx/CVE-2024-6864.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-6864"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "Wordfence",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "1.9.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/6xxx/CVE-2024-6864.json"
}
},
"related_cves": [
{
"value": "CVE-2024-6864",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 498154,
"published_at": "2024-08-20T04:28:33.896+00:00"
}