Skip to content
Heist/ feed
Back to feed
MediumFix available

Ghost 4.3.0 before 6.58.0 Incorrect Authorization via Staff Token

Type: advisorySources: OSV

Ghost versions 4.3.0 before 6.58.0 contain an authentication bypass vulnerability where lower-privilege staff users can use staff tokens to bypass post editing restrictions. Attackers with staff credentials can leverage tokens to edit posts beyond their assigned privilege level.

Products
ghost
Affected versions
Not specified
Fixed versions
6.58.0
CVEs
CVE-2026-103273
Confirmed fixed CVEs
Not specified
Updated in this feed
28 Oct 2026, 12:33 UTC · Revision 1

Source evidence

Ghost 4.3.0 before 6.58.0 Incorrect Authorization via Staff Token

core-osv · Original source

Published 9 Oct 2026, 10:44 UTC

Ghost versions 4.3.0 before 6.58.0 contain an authentication bypass vulnerability where lower-privilege staff users can use staff tokens to bypass post editing restrictions. Attackers with staff credentials can leverage tokens to edit posts beyond their assigned privilege level.

osv:BIT-ghost-2026-103273

ghost

Fixed versions: 6.58.0

Complete source record
{
  "id": "51d0fe0af0bf08bf4957a12bd18ccaa41af8107877757971c59d602f1b0030df",
  "url": "https://osv.dev/vulnerability/BIT-ghost-2026-103273",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Ghost 4.3.0 before 6.58.0 Incorrect Authorization via Staff Token",
    "summary": "Ghost versions 4.3.0 before 6.58.0 contain an authentication bypass vulnerability where lower-privilege staff users can use staff tokens to bypass post editing restrictions. Attackers with staff credentials can leverage tokens to edit posts beyond their assigned privilege level.",
    "evidence": "osv:BIT-ghost-2026-103273",
    "products": [
      {
        "name": {
          "value": "ghost",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "6.58.0",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "BIT-ghost-2026-103273",
      "aliases": [
        "BIT-ghost-2026-103273",
        "CVE-2026-103273",
        "GHSA-jj85-wvj2-r86m"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "4.3.0"
                },
                {
                  "fixed": "6.58.0"
                }
              ]
            }
          ],
          "package": {
            "name": "ghost",
            "purl": "pkg:bitnami/ghost",
            "ecosystem": "Bitnami"
          },
          "severity": [
            {
              "type": "CVSS_V4",
              "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
            }
          ],
          "database_specific": {
            "source": "https://github.com/bitnami/vulndb/tree/main/data/ghost/BIT-ghost-2026-103273.json"
          }
        }
      ],
      "modified": "2026-10-09T12:10:59.611671387Z",
      "provider": "osv",
      "references": [
        "https://github.com/TryGhost/Ghost/security/advisories/GHSA-jj85-wvj2-r86m",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-103273",
        "https://www.vulncheck.com/advisories/ghost-4.3.0-before-6.58.0-incorrect-authorization-via-staff-token"
      ],
      "provider_metadata": {
        "cpes": [
          "cpe:2.3:a:ghost:ghost:*:*:*:*:*:node.js:*:*"
        ],
        "severity": "Medium"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-103273",
        "evidence": "/aliases"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/database_specific/severity"
  },
  "source_id": "core-osv",
  "document_id": 120757,
  "published_at": "2026-10-09T10:44:51.391+00:00"
}