High
WordPress eCommerce Product Catalog plugin <= 3.6.4 - Cross Site Scripting (XSS) vulnerability
Type: advisorySources: Official CVE List
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in impleCode eCommerce Product Catalog ecommerce-product-catalog allows Reflected XSS.This issue affects eCommerce Product Catalog: from n/a through 3.6.4.
- Products
- eCommerce Product Catalog
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-115596
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 17:17 UTC · Revision 1
Source evidence
WordPress eCommerce Product Catalog plugin <= 3.6.4 - Cross Site Scripting (XSS) vulnerability
core-cve · Original sourcePublished 28 Oct 2026, 13:00 UTC
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in impleCode eCommerce Product Catalog ecommerce-product-catalog allows Reflected XSS.This issue affects eCommerce Product Catalog: from n/a through 3.6.4.
cve:CVE-2026-115596
eCommerce Product Catalog
Fixed versions: Not specified
Complete source record
{
"id": "58021d1faaacee458d7b3967cc9ed9b8490bff0e61794d7ead2d20d956550608",
"url": "https://www.cve.org/CVERecord?id=CVE-2026-115596",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WordPress eCommerce Product Catalog plugin <= 3.6.4 - Cross Site Scripting (XSS) vulnerability",
"summary": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in impleCode eCommerce Product Catalog ecommerce-product-catalog allows Reflected XSS.This issue affects eCommerce Product Catalog: from n/a through 3.6.4.",
"evidence": "cve:CVE-2026-115596",
"products": [
{
"name": {
"value": "eCommerce Product Catalog",
"evidence": "/containers/cna/affected/0/product"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "CVE-2026-115596",
"aliases": [
"CVE-2026-115596"
],
"metrics": [
{
"format": "CVSS",
"cvssV3_1": {
"scope": "CHANGED",
"version": "3.1",
"baseScore": 7.1,
"attackVector": "NETWORK",
"baseSeverity": "HIGH",
"vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L",
"integrityImpact": "LOW",
"userInteraction": "REQUIRED",
"attackComplexity": "LOW",
"availabilityImpact": "LOW",
"privilegesRequired": "NONE",
"confidentialityImpact": "LOW"
},
"scenarios": [
{
"lang": "en",
"value": "GENERAL"
}
]
}
],
"affected": [
{
"vendor": "impleCode",
"product": "eCommerce Product Catalog",
"versions": [
{
"status": "affected",
"changes": [
{
"at": "3.6.5",
"status": "unaffected"
}
],
"version": "0",
"versionType": "custom",
"lessThanOrEqual": "3.6.4"
}
],
"packageName": "ecommerce-product-catalog",
"collectionURL": "https://wordpress.org/plugins",
"defaultStatus": "unaffected"
}
],
"modified": "2026-10-28T16:07:36.842Z",
"provider": "cve",
"references": [
"https://patchstack.com/database/wordpress/plugin/ecommerce-product-catalog/vulnerability/wordpress-ecommerce-product-catalog-plugin-3-6-4-cross-site-scripting-xss-vulnerability?_s_id=cve"
],
"provider_metadata": {
"adp": [
{
"title": "CISA ADP Vulnrichment",
"metrics": [
{
"other": {
"type": "ssvc",
"content": {
"id": "CVE-2026-115596",
"role": "CISA Coordinator",
"options": [
{
"Exploitation": "none"
},
{
"Automatable": "no"
},
{
"Technical Impact": "partial"
}
],
"version": "2.0.3",
"timestamp": "2026-10-28T14:36:59.172098Z"
}
}
}
],
"providerMetadata": {
"orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"shortName": "CISA-ADP",
"dateUpdated": "2026-10-28T16:07:36.842Z"
}
}
],
"cna": {
"orgId": "21595511-bba5-4825-b968-b78d1f9984a3",
"shortName": "Patchstack",
"dateUpdated": "2026-10-28T13:00:13.283Z"
}
}
},
"related_cves": [
{
"value": "CVE-2026-115596",
"evidence": "/cveMetadata/cveId"
}
],
"security_relevant": true,
"severity_evidence": "/containers/cna/metrics"
},
"source_id": "core-cve",
"document_id": 460272,
"published_at": "2026-10-28T13:00:13.283+00:00"
}