Skip to content
Heist/ feed
Back to feed
Critical

Security advisory

Type: advisorySources: OSVCVE: CVE-2021-32714

hyper is an HTTP library for Rust. In versions prior to 0.14.10, hyper's HTTP server and client code had a flaw that could trigger an integer overflow when decoding chunk sizes that are too big. This allows possible data loss, or if combined with an upstream HTTP proxy that allows chunk sizes larger than hyper does, can result in "request smuggling" or "desync attacks." The vulnerability is patched in version 0.14.10. Two possible workarounds exist. One may reject requests manually that contain a `Transfer-Encoding` header or ensure any upstream proxy rejects `Transfer-Encoding` chunk sizes greater than what fits in 64-bit unsigned integers.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2021-32714
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 11:46 UTC · Revision 1

Source evidence

CVE-2021-32714

core-osv · Original source

Published 7 Jul 2021, 20:15 UTC

hyper is an HTTP library for Rust. In versions prior to 0.14.10, hyper's HTTP server and client code had a flaw that could trigger an integer overflow when decoding chunk sizes that are too big. This allows possible data loss, or if combined with an upstream HTTP proxy that allows chunk sizes larger than hyper does, can result in "request smuggling" or "desync attacks." The vulnerability is patched in version 0.14.10. Two possible workarounds exist. One may reject requests manually that contain a `Transfer-Encoding` header or ensure any upstream proxy rejects `Transfer-Encoding` chunk sizes greater than what fits in 64-bit unsigned integers.

osv:CVE-2021-32714
Complete source record
{
  "id": "b5c6e120c2effce8aba9889341ff2be472957df66911a1715d38e00211e93eb5",
  "url": "https://osv.dev/vulnerability/CVE-2021-32714",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2021-32714",
    "summary": "hyper is an HTTP library for Rust. In versions prior to 0.14.10, hyper's HTTP server and client code had a flaw that could trigger an integer overflow when decoding chunk sizes that are too big. This allows possible data loss, or if combined with an upstream HTTP proxy that allows chunk sizes larger than hyper does, can result in \"request smuggling\" or \"desync attacks.\" The vulnerability is patched in version 0.14.10. Two possible workarounds exist. One may reject requests manually that contain a `Transfer-Encoding` header or ensure any upstream proxy rejects `Transfer-Encoding` chunk sizes greater than what fits in 64-bit unsigned integers.",
    "evidence": "osv:CVE-2021-32714",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2021-32714",
      "aliases": [
        "CVE-2021-32714",
        "GHSA-5h46-h7hh-c6x9",
        "RUSTSEC-2021-0079"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/hyperium/hyper",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "9b69cbc2543e437f17c4a028b734f55928358675"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:hyper:hyper:*:*:*:*:*:rust:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "0.14.10"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v0.14.9",
            "v0.14.8",
            "v0.14.7",
            "v0.14.6",
            "v0.14.5",
            "v0.14.4",
            "v0.14.3",
            "v0.13.9",
            "v0.14.2",
            "v0.14.1",
            "v0.14.0",
            "v0.13.8",
            "v0.13.7",
            "v0.13.6",
            "v0.13.5",
            "v0.13.4",
            "v0.13.3",
            "v0.13.2",
            "v0.13.1",
            "v0.13.0",
            "v0.13.0-alpha.4",
            "v0.13.0-alpha.3",
            "v0.13.0-alpha.2",
            "v0.13.0-alpha.1",
            "v0.12.32",
            "v0.12.31",
            "v0.12.30",
            "v0.12.29",
            "v0.12.28",
            "v0.12.27",
            "v0.12.26",
            "v0.12.25",
            "v0.12.24",
            "v0.12.23",
            "v0.12.22",
            "v0.12.21",
            "v0.12.20",
            "v0.12.19",
            "v0.12.18",
            "v0.12.17",
            "v0.12.16",
            "v0.12.15",
            "v0.12.14",
            "v0.12.13",
            "v0.12.12",
            "v0.12.11",
            "v0.12.10",
            "v0.12.9",
            "v0.12.8",
            "v0.12.7",
            "v0.12.6",
            "v0.12.5",
            "v0.12.4",
            "v0.12.3",
            "v0.12.2",
            "v0.12.1",
            "v0.12.0",
            "v0.11.22",
            "v0.11.21",
            "v0.11.20",
            "v0.11.19",
            "v0.11.18",
            "v0.11.17",
            "v0.11.16",
            "v0.11.15",
            "v0.11.14",
            "v0.11.13",
            "v0.11.12",
            "v0.11.11",
            "v0.11.10",
            "v0.11.9",
            "v0.11.8",
            "v0.11.7",
            "v0.11.6",
            "v0.11.5",
            "v0.11.4",
            "v0.11.3",
            "v0.11.2",
            "v0.11.1",
            "v0.11.0",
            "v0.9.4",
            "v0.9.3",
            "v0.9.2",
            "v0.9.1",
            "v0.9.0",
            "v0.8.1",
            "v0.8.0",
            "v0.7.2",
            "v0.7.1",
            "v0.7.0",
            "v0.6.16",
            "v0.6.14",
            "v0.6.12",
            "v0.6.11",
            "v0.6.10",
            "v0.6.9",
            "v0.6.8",
            "v0.6.5",
            "v0.6.4",
            "v0.6.3",
            "v0.6.2",
            "v0.6.1",
            "v0.6.0",
            "v0.5.2",
            "v0.5.1",
            "v0.5.0",
            "v0.4.0",
            "v0.3.16",
            "v0.3.15",
            "v0.3.14",
            "v0.3.13",
            "v0.3.12",
            "v0.3.11",
            "v0.3.10",
            "v0.3.9",
            "v0.3.8",
            "v0.3.7",
            "v0.3.6",
            "v0.3.5",
            "v0.3.4",
            "v0.3.3",
            "v0.3.1",
            "v0.3.0",
            "v0.2.1",
            "v0.2.0",
            "v0.1.13",
            "v0.1.12",
            "v0.1.11",
            "v0.1.10",
            "v0.1.9",
            "v0.1.8",
            "v0.1.7",
            "v0.1.6",
            "v0.1.5",
            "v0.1.4",
            "v0.1.3",
            "v0.1.2",
            "v0.1.1",
            "v0.1.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-32714.json"
          }
        }
      ],
      "modified": "2026-10-20T10:54:42.597143978Z",
      "provider": "osv",
      "references": [
        "https://github.com/hyperium/hyper/security/advisories/GHSA-5h46-h7hh-c6x9"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2021-32714",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 385952,
  "published_at": "2021-07-07T20:15:08.65+00:00"
}