node-min — security advisory
Node.js before 16.4.1, 14.17.2, 12.22.2 is vulnerable to an out-of-bounds read when uv__idna_toascii() is used to convert strings to ASCII. The pointer p is read and increased without checking whether it is beyond pe, with the latter holding a pointer to the end of the buffer. This can lead to information disclosures or crashes. This function can be triggered via uv_getaddrinfo().
- Products
- node-min
- Affected versions
- Not specified
- Fixed versions
- 12.22.2, 14.17.2, 16.4.1
- CVEs
- CVE-2021-22918
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 19:54 UTC · Revision 1
Source evidence
Node.js before 16.4.1, 14.17.2, 12.22.2 is vulnerable to an out-of-bounds read when uv__idna_toascii() is used to convert strings to ASCII. The pointer p is read and increased without checking whether it is beyond pe, with the latter holding a pointer to the end of the buffer. This can lead to information disclosures or crashes. This function can be triggered via uv_getaddrinfo().
osv:BIT-node-min-2021-22918
node-min
Fixed versions: 12.22.2, 14.17.2, 16.4.1
Complete source record
{
"id": "a751b8148000e9e79c76f9a7867565325a431dbacb0874f53c11a2ea7e97753e",
"url": "https://osv.dev/vulnerability/BIT-node-min-2021-22918",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "BIT-node-min-2021-22918",
"summary": "Node.js before 16.4.1, 14.17.2, 12.22.2 is vulnerable to an out-of-bounds read when uv__idna_toascii() is used to convert strings to ASCII. The pointer p is read and increased without checking whether it is beyond pe, with the latter holding a pointer to the end of the buffer. This can lead to information disclosures or crashes. This function can be triggered via uv_getaddrinfo().",
"evidence": "osv:BIT-node-min-2021-22918",
"products": [
{
"name": {
"value": "node-min",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "12.22.2",
"evidence": "/affected/0/ranges"
},
{
"value": "14.17.2",
"evidence": "/affected/0/ranges"
},
{
"value": "16.4.1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "BIT-node-min-2021-22918",
"aliases": [
"BIT-node-2021-22918",
"BIT-node-min-2021-22918",
"CVE-2021-22918"
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "12.0.0"
},
{
"fixed": "12.22.2"
},
{
"introduced": "14.0.0"
},
{
"fixed": "14.17.2"
},
{
"introduced": "16.0.0"
},
{
"fixed": "16.4.1"
}
]
}
],
"package": {
"name": "node-min",
"purl": "pkg:bitnami/node-min",
"ecosystem": "Bitnami"
},
"severity": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N"
}
],
"database_specific": {
"source": "https://github.com/bitnami/vulndb/tree/main/data/node-min/BIT-node-min-2021-22918.json"
}
}
],
"modified": "2026-10-16T09:45:30.444343296Z",
"provider": "osv",
"references": [
"https://hackerone.com/reports/1209681",
"https://nodejs.org/en/blog/vulnerability/july-2021-security-releases/",
"https://security.gentoo.org/glsa/202401-23",
"https://security.netapp.com/advisory/ntap-20210805-0003/",
"https://nvd.nist.gov/vuln/detail/CVE-2021-22918"
],
"provider_metadata": {
"cpes": [
"cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:*"
],
"severity": "Medium"
}
},
"related_cves": [
{
"value": "CVE-2021-22918",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 338474,
"published_at": "2024-12-16T14:05:47.622+00:00"
}