High
Apache Ignite: REST HTTP arbitrary file read vulnerability
Type: advisorySources: OSV
Relative Path Traversal vulnerability in Apache Ignite REST API. Authenticated REST API users can read any file on the server with "cmd=log" command and a log path crafted in a certain way. This issue affects Apache Ignite: from 2.0.0 through 2.17.0. Users are recommended to upgrade to version 2.18.0, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-48977
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 14:00 UTC · Revision 1
Source evidence
Apache Ignite: REST HTTP arbitrary file read vulnerability
core-osv · Original sourcePublished 28 May 2026, 08:58 UTC
Relative Path Traversal vulnerability in Apache Ignite REST API. Authenticated REST API users can read any file on the server with "cmd=log" command and a log path crafted in a certain way. This issue affects Apache Ignite: from 2.0.0 through 2.17.0. Users are recommended to upgrade to version 2.18.0, which fixes the issue.
osv:CVE-2025-48977
Complete source record
{
"id": "66efe424e4fc4476c78ed8cc3d01a5513d00356d392caea8f3df2fa11dddbe66",
"url": "https://osv.dev/vulnerability/CVE-2025-48977",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Ignite: REST HTTP arbitrary file read vulnerability",
"summary": "Relative Path Traversal vulnerability in Apache Ignite REST API. Authenticated REST API users can read any file on the server with \"cmd=log\" command and a log path crafted in a certain way. This issue affects Apache Ignite: from 2.0.0 through 2.17.0. Users are recommended to upgrade to version 2.18.0, which fixes the issue.",
"evidence": "osv:CVE-2025-48977",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2025-48977",
"aliases": [
"CVE-2025-48977",
"GHSA-v45h-mqf4-6939"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/ignite",
"type": "GIT",
"events": [
{
"introduced": "d4eef3c68ff116ee34bc13648cd82c640b3ea072"
},
{
"fixed": "d49adada19829f2186dfb5e2e8d12e7d79c1c3a7"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:ignite:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.18.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-48977.json"
}
}
],
"modified": "2026-10-28T02:30:35.792712356Z",
"provider": "osv",
"references": [
"https://repo.maven.apache.org/maven2",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/48xxx/CVE-2025-48977.json",
"https://lists.apache.org/thread/hgct6918sowd8l58yjohryhpxx81t4n1",
"https://nvd.nist.gov/vuln/detail/CVE-2025-48977"
],
"provider_metadata": {
"cwe_ids": [
"CWE-23"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "2.0.0"
},
{
"last_affected": "2.17.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/48xxx/CVE-2025-48977.json"
}
},
"related_cves": [
{
"value": "CVE-2025-48977",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 503405,
"published_at": "2026-05-28T08:58:06.822+00:00"
}