Skip to content
Heist/ feed
Back to feed
Medium

Apache Superset: Metadata db write access can lead to remote code execution

Type: advisorySources: OSV

If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend. The Superset metadata db is an 'internal' component that is typically only accessible directly by the system administrator and the superset process itself. Gaining access to that database should be difficult and require significant privileges. This vulnerability impacts Apache Superset versions 1.5.0 up to and including 2.1.0. Users are recommended to upgrade to version 2.1.1 or later.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2023-37941
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 07:01 UTC · Revision 1

Source evidence

Apache Superset: Metadata db write access can lead to remote code execution

core-osv · Original source

Published 6 Sept 2023, 13:06 UTC

If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend. The Superset metadata db is an 'internal' component that is typically only accessible directly by the system administrator and the superset process itself. Gaining access to that database should be difficult and require significant privileges. This vulnerability impacts Apache Superset versions 1.5.0 up to and including 2.1.0. Users are recommended to upgrade to version 2.1.1 or later.

osv:CVE-2023-37941
Complete source record
{
  "id": "03a2fbfccdf12a8b7ff784beefffc4a985330501fccfa802a27ba91ea67f545a",
  "url": "https://osv.dev/vulnerability/CVE-2023-37941",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache Superset: Metadata db write access can lead to remote code execution",
    "summary": "If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend. The Superset metadata db is an 'internal' component that is typically only accessible directly by the system administrator and the superset process itself. Gaining access to that database should be difficult and require significant privileges. This vulnerability impacts Apache Superset versions 1.5.0 up to and including 2.1.0. Users are recommended to upgrade to version 2.1.1 or later.",
    "evidence": "osv:CVE-2023-37941",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2023-37941",
      "aliases": [
        "BIT-superset-2023-37941",
        "CVE-2023-37941",
        "GHSA-fj4x-m62j-wvwg",
        "PYSEC-2026-1175"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/superset",
              "type": "GIT",
              "events": [
                {
                  "introduced": "054e6b23348e4a26efbe50109def40e721e49a2c"
                },
                {
                  "last_affected": "2817aebd69dc7d199ec45d973a2079f35e5658b6"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "1.5.0"
                      },
                      {
                        "last_affected": "2.1.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-37941.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:50.021113227Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/37xxx/CVE-2023-37941.json",
        "https://lists.apache.org/thread/6qk1zscc06yogxxfgz2bh2bvz6vh9g7h",
        "https://nvd.nist.gov/vuln/detail/CVE-2023-37941"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-502"
        ],
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "1.5.0"
                  },
                  {
                    "last_affected": "2.1.0"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/37xxx/CVE-2023-37941.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2023-37941",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 518578,
  "published_at": "2023-09-06T13:06:20.879+00:00"
}