Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2018-17614

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Losant Arduino MQTT Client prior to V2.7. User interaction is not required to exploit this vulnerability. The specific flaw exists within the parsing of MQTT PUBLISH packets. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-6436.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2018-17614
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 10:05 UTC · Revision 1

Source evidence

CVE-2018-17614

core-osv · Original source

Published 13 Nov 2018, 21:29 UTC

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Losant Arduino MQTT Client prior to V2.7. User interaction is not required to exploit this vulnerability. The specific flaw exists within the parsing of MQTT PUBLISH packets. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-6436.

osv:CVE-2018-17614
Complete source record
{
  "id": "4361cdcf1b9257df82650eaa0576e1367f89d3483ef8b8be10779f7e87dbfa7f",
  "url": "https://osv.dev/vulnerability/CVE-2018-17614",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2018-17614",
    "summary": "This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Losant Arduino MQTT Client prior to V2.7. User interaction is not required to exploit this vulnerability. The specific flaw exists within the parsing of MQTT PUBLISH packets. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-6436.",
    "evidence": "osv:CVE-2018-17614",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2018-17614",
      "aliases": [
        "CVE-2018-17614"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/knolleary/pubsubclient",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "26ce89fa476da85399b736f885274d67676dacb8"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:losant:arduino_mqtt_client:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.7"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "26ce89fa476da85399b736f885274d67676dacb8"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v2.7"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v2.6",
            "v2.5",
            "2.4",
            "v2.3",
            "v2.2",
            "v2.1",
            "v2.0",
            "v1.9.1",
            "v1.9",
            "v1.8",
            "v1.7",
            "v1.6",
            "v1.5",
            "v1.4",
            "v1.3",
            "v1.2",
            "v1.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-17614.json"
          }
        }
      ],
      "modified": "2026-10-20T10:49:53.222547964Z",
      "provider": "osv",
      "references": [
        "https://github.com/knolleary/pubsubclient/releases/tag/v2.7",
        "https://zerodayinitiative.com/advisories/ZDI-18-1337"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2018-17614",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 380922,
  "published_at": "2018-11-13T21:29:00.293+00:00"
}