OpenCTI's lack of Rate Limit lead to OTP brute forcing
OpenCTI is an open-source cyber threat intelligence platform. In versions below 6.2.18, because the function to limit the rate of OTP does not exist, an attacker with valid credentials or a malicious user who commits internal fraud can break through the two-factor authentication and hijack the account. This is because the otpLogin mutation does not implement One Time Password rate limiting. As of time of publication, it is unknown whether a patch is available.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-45404
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 01:17 UTC · Revision 1
Source evidence
OpenCTI's lack of Rate Limit lead to OTP brute forcing
core-osv · Original sourcePublished 11 Dec 2024, 22:01 UTC
OpenCTI is an open-source cyber threat intelligence platform. In versions below 6.2.18, because the function to limit the rate of OTP does not exist, an attacker with valid credentials or a malicious user who commits internal fraud can break through the two-factor authentication and hijack the account. This is because the otpLogin mutation does not implement One Time Password rate limiting. As of time of publication, it is unknown whether a patch is available.
osv:CVE-2024-45404
Complete source record
{
"id": "b66c94f079accbf9375a35a22834a51069901e6cbb75c07d2c3e65ff37275bf1",
"url": "https://osv.dev/vulnerability/CVE-2024-45404",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "OpenCTI's lack of Rate Limit lead to OTP brute forcing",
"summary": "OpenCTI is an open-source cyber threat intelligence platform. In versions below 6.2.18, because the function to limit the rate of OTP does not exist, an attacker with valid credentials or a malicious user who commits internal fraud can break through the two-factor authentication and hijack the account. This is because the otpLogin mutation does not implement One Time Password rate limiting. As of time of publication, it is unknown whether a patch is available.",
"evidence": "osv:CVE-2024-45404",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2024-45404",
"aliases": [
"CVE-2024-45404",
"GHSA-hg56-r6hh-56j7",
"PYSEC-2024-297"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/opencti-platform/opencti",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "839fca43230f54fd4c71d08e03410ba151be2ea8"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "6.2.8"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:citeum:opencti:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "6.2.18"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"6.2.7",
"6.2.6",
"6.2.5",
"6.2.4",
"6.2.3",
"6.2.2",
"6.2.1",
"6.2.0",
"6.1.12",
"6.1.10",
"6.1.9",
"6.1.8",
"6.1.7",
"6.1.6",
"6.1.5",
"6.1.4",
"6.1.3",
"6.1.2",
"6.1.1",
"6.1.0",
"6.0.10",
"6.0.9",
"6.0.8",
"6.0.7",
"6.0.6",
"6.0.5",
"6.0.4",
"6.0.3",
"6.0.2",
"6.0.0",
"5.12.27",
"5.12.26",
"5.12.25",
"5.12.24",
"5.12.23",
"5.12.22",
"5.12.21",
"5.12.20",
"5.12.19",
"5.12.18",
"5.12.17",
"5.12.16",
"5.12.15",
"5.12.14",
"5.12.13",
"5.12.12",
"5.12.11",
"5.12.10",
"5.12.9",
"5.12.8",
"5.12.7",
"5.12.6",
"5.12.5",
"5.12.4",
"5.12.3",
"5.12.2",
"5.12.1",
"5.12.0",
"5.11.13",
"5.11.12",
"5.11.11",
"5.11.10",
"5.11.9",
"5.11.8",
"5.11.7",
"5.11.6",
"5.11.5",
"5.11.4",
"5.11.3",
"5.11.2",
"5.11.1",
"5.11.0",
"5.10.3",
"5.10.2",
"5.10.1",
"5.10.0",
"5.9.6",
"5.9.5",
"5.9.4",
"5.9.3",
"5.9.2",
"5.9.1",
"5.9.0",
"5.8.7",
"5.8.6",
"5.8.5",
"5.8.4",
"5.8.3",
"5.8.2",
"5.8.1",
"5.8.0",
"5.7.6",
"5.7.5",
"5.7.4",
"5.7.3",
"5.7.2",
"5.7.1",
"5.7.0",
"5.6.2",
"5.6.1",
"5.6.0",
"5.5.4",
"5.5.3",
"5.5.2",
"5.5.1",
"5.5.0",
"5.4.1",
"5.4.0",
"5.3.17",
"5.3.16",
"5.3.15",
"5.3.14",
"5.3.13",
"5.3.12",
"5.3.11",
"5.3.10",
"5.3.9",
"5.3.8",
"5.3.7",
"5.3.6",
"5.3.5",
"5.3.4",
"5.3.3",
"5.3.2",
"5.3.1",
"5.3.0",
"5.2.4",
"5.2.3",
"5.2.2",
"5.2.1",
"5.2.0",
"5.1.4",
"5.1.3",
"5.1.2",
"5.1.1",
"5.1.0",
"5.0.3",
"5.0.2",
"5.0.1",
"5.0.0",
"4.5.5",
"4.5.4",
"4.5.3",
"4.5.2",
"4.5.1",
"4.5.0",
"4.4.1",
"4.4.0",
"4.3.5",
"4.3.4",
"4.3.3",
"4.3.2",
"4.3.1",
"4.3.0",
"4.2.4",
"4.2.3",
"4.2.2",
"4.2.1",
"4.2.0",
"4.1.2",
"4.1.1",
"4.1.0",
"4.0.7",
"4.0.6",
"4.0.5",
"4.0.4",
"4.0.3",
"4.0.2",
"4.0.1",
"4.0.0",
"3.3.2",
"3.3.1",
"3.3.0",
"3.2.2",
"3.2.0",
"3.0.3",
"3.0.2",
"3.0.1",
"3.0.0",
"2.1.4",
"2.1.3",
"2.1.2",
"2.1.1",
"2.1.0",
"2.0.2",
"2.0.1",
"1.1.2",
"1.1.0",
"1.0.2",
"1.0.1",
"1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-45404.json"
}
}
],
"modified": "2026-10-28T02:30:41.293319783Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/45xxx/CVE-2024-45404.json",
"https://github.com/OpenCTI-Platform/opencti/security/advisories/GHSA-hg56-r6hh-56j7",
"https://nvd.nist.gov/vuln/detail/CVE-2024-45404"
],
"provider_metadata": {
"cwe_ids": [
"CWE-287"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/45xxx/CVE-2024-45404.json"
}
},
"related_cves": [
{
"value": "CVE-2024-45404",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 508968,
"published_at": "2024-12-11T22:01:46.667+00:00"
}