node-brace-expansion — security advisory
brace-expansion through 5.0.7 is vulnerable to denial of service via memory exhaustion. The expand() function limits the number of results with a max option (default 100,000) but does not bound the length of each result string. By chaining multiple brace groups, an attacker keeps the result count under the limit while making each result progressively longer, so total memory scales with both count and string length until the process hits a fatal, uncatchable out-of-memory error. About 7.5 KB of input ('{a,b}'.repeat(1500)) crashes a default Node.js process. Any application that passes attacker-influenced strings to brace-expansion.expand() - directly or transitively via minimatch / glob brace patterns - can be crashed by a small request. Fixed in 5.0.8 by adding a maxLength option (default 4,000,000) that bounds accumulated output and intermediate arrays.
- Products
- node-brace-expansion
- Affected versions
- 2.0.1+~1.1.0-1, 2.0.1+~1.1.0-2, 2.0.1-2, 2.0.3+~1.1.2-1, 2.0.3+~1.1.2-2, 2.0.3+~1.1.2-3, 2.1.4+~1.1.2-1, 2.1.7+~1.1.2-1
- Fixed versions
- Not specified
- CVEs
- CVE-2026-14257
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 09:56 UTC · Revision 2
Source evidence
brace-expansion through 5.0.7 is vulnerable to denial of service via memory exhaustion. The expand() function limits the number of results with a max option (default 100,000) but does not bound the length of each result string. By chaining multiple brace groups, an attacker keeps the result count under the limit while making each result progressively longer, so total memory scales with both count and string length until the process hits a fatal, uncatchable out-of-memory error. About 7.5 KB of input ('{a,b}'.repeat(1500)) crashes a default Node.js process. Any application that passes attacker-influenced strings to brace-expansion.expand() - directly or transitively via minimatch / glob brace patterns - can be crashed by a small request. Fixed in 5.0.8 by adding a maxLength option (default 4,000,000) that bounds accumulated output and intermediate arrays.
osv:DEBIAN-CVE-2026-14257
node-brace-expansion
Fixed versions: Not specified
node-brace-expansion
Fixed versions: Not specified
node-brace-expansion
Fixed versions: Not specified
Complete source record
{
"id": "5f9b9c6cbdf3911f0a6019854952c6e21896f066acc4cd70e67c154e3a85305a",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-14257",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-14257",
"summary": "brace-expansion through 5.0.7 is vulnerable to denial of service via memory exhaustion. The expand() function limits the number of results with a max option (default 100,000) but does not bound the length of each result string. By chaining multiple brace groups, an attacker keeps the result count under the limit while making each result progressively longer, so total memory scales with both count and string length until the process hits a fatal, uncatchable out-of-memory error. About 7.5 KB of input ('{a,b}'.repeat(1500)) crashes a default Node.js process. Any application that passes attacker-influenced strings to brace-expansion.expand() - directly or transitively via minimatch / glob brace patterns - can be crashed by a small request. Fixed in 5.0.8 by adding a maxLength option (default 4,000,000) that bounds accumulated output and intermediate arrays.",
"evidence": "osv:DEBIAN-CVE-2026-14257",
"products": [
{
"name": {
"value": "node-brace-expansion",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.0.1+~1.1.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.0.1+~1.1.0-2",
"evidence": "/affected/0/versions"
},
{
"value": "2.0.1-2",
"evidence": "/affected/0/versions"
},
{
"value": "2.0.3+~1.1.2-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.0.3+~1.1.2-2",
"evidence": "/affected/0/versions"
},
{
"value": "2.0.3+~1.1.2-3",
"evidence": "/affected/0/versions"
},
{
"value": "2.1.4+~1.1.2-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.1.7+~1.1.2-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "node-brace-expansion",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.0.1+~1.1.0-2",
"evidence": "/affected/1/versions"
},
{
"value": "2.0.3+~1.1.2-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.0.3+~1.1.2-2",
"evidence": "/affected/1/versions"
},
{
"value": "2.0.3+~1.1.2-3",
"evidence": "/affected/1/versions"
},
{
"value": "2.1.4+~1.1.2-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.1.7+~1.1.2-1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "node-brace-expansion",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.0.1+~1.1.0-2",
"evidence": "/affected/2/versions"
},
{
"value": "2.0.3+~1.1.2-1",
"evidence": "/affected/2/versions"
},
{
"value": "2.0.3+~1.1.2-2",
"evidence": "/affected/2/versions"
},
{
"value": "2.0.3+~1.1.2-3",
"evidence": "/affected/2/versions"
},
{
"value": "2.1.4+~1.1.2-1",
"evidence": "/affected/2/versions"
},
{
"value": "2.1.7+~1.1.2-1",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2026-14257",
"aliases": [
"DEBIAN-CVE-2026-14257"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-brace-expansion",
"purl": "pkg:deb/debian/node-brace-expansion?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"2.0.1+~1.1.0-1",
"2.0.1+~1.1.0-2",
"2.0.1-2",
"2.0.3+~1.1.2-1",
"2.0.3+~1.1.2-2",
"2.0.3+~1.1.2-3",
"2.1.4+~1.1.2-1",
"2.1.7+~1.1.2-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-14257.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-brace-expansion",
"purl": "pkg:deb/debian/node-brace-expansion?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"2.0.1+~1.1.0-2",
"2.0.3+~1.1.2-1",
"2.0.3+~1.1.2-2",
"2.0.3+~1.1.2-3",
"2.1.4+~1.1.2-1",
"2.1.7+~1.1.2-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-14257.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-brace-expansion",
"purl": "pkg:deb/debian/node-brace-expansion?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"2.0.1+~1.1.0-2",
"2.0.3+~1.1.2-1",
"2.0.3+~1.1.2-2",
"2.0.3+~1.1.2-3",
"2.1.4+~1.1.2-1",
"2.1.7+~1.1.2-1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-14257.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-25T10:00:59.169755753Z",
"provider": "osv",
"upstream": [
"CVE-2026-14257"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-14257"
]
},
"related_cves": [
{
"value": "CVE-2026-14257",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 445347,
"published_at": "2026-07-23T14:17:00.25+00:00"
}