@keystone-6/core vulnerable to field-level access-control bypass for multiselect field
@keystone-6/core is a core package for Keystone 6, a content management system for Node.js. Starting with version 2.2.0 and prior to version 2.3.1, users who expected their `multiselect` fields to use the field-level access control - if configured - are vulnerable to their field-level access control not being used. List-level access control is not affected. Field-level access control for fields other than `multiselect` are not affected. Version 2.3.1 contains a fix for this issue. As a workaround, stop using the `multiselect` field.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-39322
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 13:51 UTC · Revision 1
Source evidence
@keystone-6/core vulnerable to field-level access-control bypass for multiselect field
core-osv · Original sourcePublished 25 Oct 2022, 00:00 UTC
@keystone-6/core is a core package for Keystone 6, a content management system for Node.js. Starting with version 2.2.0 and prior to version 2.3.1, users who expected their `multiselect` fields to use the field-level access control - if configured - are vulnerable to their field-level access control not being used. List-level access control is not affected. Field-level access control for fields other than `multiselect` are not affected. Version 2.3.1 contains a fix for this issue. As a workaround, stop using the `multiselect` field.
osv:CVE-2022-39322
Complete source record
{
"id": "f4a9e59a8c4f4574807ca88417dabf9069e490a388f0aefe44b08a7c407415e6",
"url": "https://osv.dev/vulnerability/CVE-2022-39322",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "@keystone-6/core vulnerable to field-level access-control bypass for multiselect field",
"summary": "@keystone-6/core is a core package for Keystone 6, a content management system for Node.js. Starting with version 2.2.0 and prior to version 2.3.1, users who expected their `multiselect` fields to use the field-level access control - if configured - are vulnerable to their field-level access control not being used. List-level access control is not affected. Field-level access control for fields other than `multiselect` are not affected. Version 2.3.1 contains a fix for this issue. As a workaround, stop using the `multiselect` field.",
"evidence": "osv:CVE-2022-39322",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2022-39322",
"aliases": [
"CVE-2022-39322",
"GHSA-6mhr-52mv-6v6f"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/keystonejs/keystone",
"type": "GIT",
"events": [
{
"introduced": "e146f5a69eab84537afcde10ff571d4fd7cf4ffc"
},
{
"fixed": "e586af45089a2ca1391d2a86ed585694b690b6c3"
},
{
"fixed": "65c6ee3deef23605fc72b80230908696a7a65e7c"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:keystonejs:keystone:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "2.2.0"
},
{
"fixed": "2.3.1"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "65c6ee3deef23605fc72b80230908696a7a65e7c"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"@keystone-alpha/auth-passport@4.1.0",
"@keystone-alpha/auth-passport@4.0.1",
"@keystone-alpha/test-utils@2.3.0",
"@keystone-alpha/keystone@13.0.0",
"@keystone-alpha/auth-passport@4.0.0",
"@keystone-alpha/app-graphql@7.0.0",
"@keystone-alpha/app-admin-ui@5.5.2",
"@keystone-alpha/adapter-mongoose@4.0.4",
"@keystone-alpha/adapter-knex@4.0.7",
"@keystone-alpha/auth-passport@3.1.0",
"@keystone-alpha/adapter-knex@4.0.6",
"@keystone-alpha/list-plugins@1.0.0",
"@keystone-alpha/app-admin-ui@5.5.1",
"@keystone-alpha/fields@10.6.2",
"@keystone-alpha/keystone@12.0.1",
"@keystone-alpha/test-utils@2.2.4",
"@keystone-alpha/keystone@12.0.0",
"@keystone-alpha/adapter-mongoose@4.0.3",
"@keystone-alpha/adapter-knex@4.0.5",
"@keystone-alpha/fields@10.6.1",
"@keystone-alpha/fields@10.6.0",
"@keystone-alpha/app-admin-ui@5.5.0",
"@keystone-alpha/test-utils@2.2.3",
"@keystone-alpha/keystone@11.0.0",
"@keystone-alpha/fields@10.5.0",
"@keystone-alpha/auth-password@1.0.0",
"@keystone-alpha/app-admin-ui@5.4.0",
"@keystone-alpha/adapter-mongoose@4.0.2",
"@keystone-alpha/adapter-knex@4.0.4",
"create-keystone-app@1.0.1",
"@keystone-alpha/test-utils@2.2.2",
"@keystone-alpha/keystone@10.5.0",
"@keystone-alpha/fields@10.4.0",
"@keystone-alpha/fields-mongoid@1.1.0",
"@keystone-alpha/auth-passport@3.0.0",
"@keystone-alpha/app-admin-ui@5.3.0",
"@keystone-alpha/adapter-mongoose@4.0.1",
"@keystone-alpha/adapter-knex@4.0.3",
"create-keystone-app@1.0.0",
"@keystone-alpha/keystone@10.4.0",
"@keystone-alpha/keystone@10.3.0",
"@keystone-alpha/fields@10.3.0",
"@keystone-alpha/keystone@10.2.0",
"@keystone-alpha/access-control@1.1.0",
"@keystone-alpha/keystone@10.1.0",
"@keystone-alpha/adapter-knex@4.0.2",
"@keystone-alpha/adapter-knex@4.0.1",
"@keystone-alpha/test-utils@2.2.1",
"@keystone-alpha/keystone@10.0.0",
"@keystone-alpha/fields@10.2.0",
"@keystone-alpha/fields-mongoid@1.0.2",
"@keystone-alpha/fields-datetime-utc@1.0.1",
"@keystone-alpha/fields-auto-increment@1.0.1",
"@keystone-alpha/field-content@2.1.0",
"@keystone-alpha/build-field-types@1.0.5",
"@keystone-alpha/app-static@1.1.0",
"@keystone-alpha/app-admin-ui@5.2.0",
"@keystone-alpha/adapter-mongoose@4.0.0",
"@keystone-alpha/adapter-knex@4.0.0",
"@arch-ui/select@0.0.8",
"@arch-ui/options@0.0.9",
"@arch-ui/drawer@0.0.10",
"@arch-ui/day-picker@0.0.11",
"Typescript-Convert",
"@keystone-alpha/test-utils@2.2.0",
"@keystone-alpha/keystone@9.1.0",
"@keystone-alpha/fields@10.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-39322.json"
}
}
],
"modified": "2026-10-28T02:30:29.353133491Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39322.json",
"https://github.com/keystonejs/keystone/security/advisories/GHSA-6mhr-52mv-6v6f",
"https://nvd.nist.gov/vuln/detail/CVE-2022-39322",
"https://github.com/keystonejs/keystone/commit/65c6ee3deef23605fc72b80230908696a7a65e7c"
],
"provider_metadata": {
"cwe_ids": [
"CWE-285"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39322.json"
}
},
"related_cves": [
{
"value": "CVE-2022-39322",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 496098,
"published_at": "2022-10-25T00:00:00+00:00"
}