Medium
Apache SkyWalking: Stored XSS vulnerability
Type: advisorySources: OSV
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache SkyWalking. This issue affects Apache SkyWalking: <= 10.2.0. Users are recommended to upgrade to version 10.3.0, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-54057
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 09:53 UTC · Revision 1
Source evidence
Apache SkyWalking: Stored XSS vulnerability
core-osv · Original sourcePublished 27 Nov 2025, 11:47 UTC
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache SkyWalking. This issue affects Apache SkyWalking: <= 10.2.0. Users are recommended to upgrade to version 10.3.0, which fixes the issue.
osv:CVE-2025-54057
Complete source record
{
"id": "44d99ceba222287a41af3b5b3553f651c76a07860e667bba66462bb3a54b0ef4",
"url": "https://osv.dev/vulnerability/CVE-2025-54057",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache SkyWalking: Stored XSS vulnerability",
"summary": "Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache SkyWalking. This issue affects Apache SkyWalking: <= 10.2.0. Users are recommended to upgrade to version 10.3.0, which fixes the issue.",
"evidence": "osv:CVE-2025-54057",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-54057",
"aliases": [
"CVE-2025-54057",
"GHSA-v6x2-4q87-rf82"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/skywalking",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "05c5b245ad39efc3910fef6d0fc5f21fd9653afd"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:skywalking:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "10.3.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v8.3.0.2",
"v3.2.4",
"v3.2.3",
"v3.2.2",
"v3.2.1",
"v3.2",
"v3.1.1",
"v3.1",
"v3.0.1-2017",
"v3.0-2017",
"v2.1-2017",
"v1.0-Final",
"1.0-beta",
"1.0-alpha2",
"1.0-alpha1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-54057.json"
}
}
],
"modified": "2026-10-28T02:30:43.577354277Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/54xxx/CVE-2025-54057.json",
"https://lists.apache.org/thread/sl2x2tx8y007x0mo746yddx2lvnv9tcr",
"https://nvd.nist.gov/vuln/detail/CVE-2025-54057"
],
"provider_metadata": {
"cwe_ids": [
"CWE-80"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "10.2.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/54xxx/CVE-2025-54057.json"
}
},
"related_cves": [
{
"value": "CVE-2025-54057",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 511540,
"published_at": "2025-11-27T11:47:32.947+00:00"
}