Critical
Security advisory
Ignition before 2.5.2, as used in Laravel and other products, allows unauthenticated remote attackers to execute arbitrary code because of insecure usage of file_get_contents() and file_put_contents(). This is exploitable on sites using debug mode with Laravel before 8.4.2.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-3129
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:45 UTC · Revision 1
Source evidence
Ignition before 2.5.2, as used in Laravel and other products, allows unauthenticated remote attackers to execute arbitrary code because of insecure usage of file_get_contents() and file_put_contents(). This is exploitable on sites using debug mode with Laravel before 8.4.2.
osv:CVE-2021-3129
Complete source record
{
"id": "385e8bd3fdfc815d5e3df4bf61ef1ee66bfd427777fbee1a137052c7eeba4ff6",
"url": "https://osv.dev/vulnerability/CVE-2021-3129",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-3129",
"summary": "Ignition before 2.5.2, as used in Laravel and other products, allows unauthenticated remote attackers to execute arbitrary code because of insecure usage of file_get_contents() and file_put_contents(). This is exploitable on sites using debug mode with Laravel before 8.4.2.",
"evidence": "osv:CVE-2021-3129",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2021-3129",
"aliases": [
"CVE-2021-3129",
"GHSA-4qwp-7c67-jmcc"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/facade/ignition",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "08668034beb185fa2ac6f09b1034eaa440952ace"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:facade:ignition:*:*:*:*:*:laravel:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.5.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.4.1",
"2.5.1",
"2.5.0",
"2.4.0",
"2.3.8",
"2.3.7",
"2.3.6",
"2.3.5",
"2.3.4",
"2.3.3",
"2.3.2",
"2.3.1",
"2.3.0",
"2.2.0",
"2.1.0",
"2.0.10",
"2.0.9",
"2.0.8",
"2.0.7",
"2.0.6",
"2.0.5",
"2.0.4",
"2.0.2",
"2.0.1",
"2.0.0",
"1.16.0",
"1.15.0",
"1.14.0",
"1.13.1",
"1.13.0",
"1.12.1",
"1.12.0",
"1.11.2",
"1.11.1",
"1.10.0",
"1.11.0",
"1.9.2",
"1.9.1",
"1.9.0",
"1.8.4",
"1.8.2",
"1.8.1",
"1.8.0",
"1.7.1",
"1.7.0",
"1.6.9",
"1.6.8",
"1.6.7",
"1.6.6",
"1.6.5",
"1.6.4",
"1.6.3",
"1.6.2",
"1.6.1",
"1.6.0",
"1.4.2",
"1.3.0",
"1.2.0",
"1.1.1",
"1.1.0",
"1.0.4",
"1.0.3",
"1.0.1",
"1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-3129.json"
}
}
],
"modified": "2026-10-20T10:54:39.937339209Z",
"provider": "osv",
"references": [
"https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-3129",
"https://github.com/facade/ignition/pull/334",
"https://www.ambionics.io/blog/laravel-debug-rce"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-3129",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 385829,
"published_at": "2021-01-12T15:15:16.453+00:00"
}