Security advisory
Prism is vulnerable to Cross-Site Scripting. The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the _Previewers_ plugin (>=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0). This problem is fixed in version 1.21.0. To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2020-15138
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 10:52 UTC · Revision 1
Source evidence
Prism is vulnerable to Cross-Site Scripting. The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the _Previewers_ plugin (>=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0). This problem is fixed in version 1.21.0. To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.
osv:CVE-2020-15138
Complete source record
{
"id": "28b8c067954bde60e3bdb2bada31d5ca20e251f12c81e0d0fe257492db762c03",
"url": "https://osv.dev/vulnerability/CVE-2020-15138",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2020-15138",
"summary": "Prism is vulnerable to Cross-Site Scripting. The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the _Previewers_ plugin (>=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0). This problem is fixed in version 1.21.0. To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.",
"evidence": "osv:CVE-2020-15138",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2020-15138",
"aliases": [
"CVE-2020-15138",
"GHSA-wvhm-4hhf-97x9"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/prismjs/prism",
"type": "GIT",
"events": [
{
"introduced": "a6c0d028fdbfc4fca733ad42f86b60189b3772f0"
},
{
"fixed": "187c8a607ee70c7914682870156faa31ed01f001"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:prismjs:previewers:*:*:*:*:*:prismjs:*:*",
"range": [
{
"introduced": "1.1.0"
},
{
"fixed": "1.21.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v1.20.0",
"v1.19.0",
"v1.18.0",
"v1.17.1",
"v1.17.0",
"v1.16.0",
"v1.15.0",
"v1.14.0",
"v1.13.0",
"v1.12.2",
"v1.12.1",
"v1.12.0",
"v1.11.0",
"v1.10.0",
"v1.9.0",
"v1.8.4",
"v1.8.3",
"v1.8.2",
"v1.8.1",
"v1.8.0",
"v1.7.0",
"v1.6.0",
"1.5.1",
"1.5.0",
"v1.4.1",
"1.4.0",
"v1.3.0",
"v1.2.0",
"v1.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-15138.json"
}
}
],
"modified": "2026-10-20T10:51:53.290424680Z",
"provider": "osv",
"references": [
"https://github.com/PrismJS/prism/security/advisories/GHSA-wvhm-4hhf-97x9",
"https://prismjs.com/plugins/previewers/#disabling-a-previewer",
"https://github.com/PrismJS/prism/pull/2506/commits/7bd7de05edf71112a3a77f87901a2409c9c5c20c"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2020-15138",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 383088,
"published_at": "2020-08-07T17:15:10.45+00:00"
}