vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.
- Products
- vllm
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-115915
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 19:50 UTC · Revision 1
Source evidence
vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE
core-cve · Original sourcePublished 26 Oct 2026, 17:16 UTC
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.
cve:CVE-2026-115915
vllm
Fixed versions: Not specified
Complete source record
{
"id": "7916c891c2c72497a7cc1f494b285be7971dbd8e5942aea0af706daf05adf2e2",
"url": "https://www.cve.org/CVERecord?id=CVE-2026-115915",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE",
"summary": "vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.",
"evidence": "cve:CVE-2026-115915",
"products": [
{
"name": {
"value": "vllm",
"evidence": "/containers/cna/affected/0/product"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "CVE-2026-115915",
"aliases": [
"CVE-2026-115915"
],
"metrics": [
{
"cvssV3_1": {
"scope": "UNCHANGED",
"version": "3.1",
"baseScore": 8.1,
"attackVector": "NETWORK",
"baseSeverity": "HIGH",
"vectorString": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H",
"integrityImpact": "HIGH",
"userInteraction": "NONE",
"attackComplexity": "HIGH",
"availabilityImpact": "HIGH",
"privilegesRequired": "NONE",
"confidentialityImpact": "HIGH"
}
}
],
"affected": [
{
"vendor": "vllm-project",
"product": "vllm",
"versions": [
{
"status": "affected",
"version": "< 0.32.0"
}
]
}
],
"modified": "2026-10-26T19:35:10.423Z",
"provider": "cve",
"references": [
"https://github.com/vllm-project/vllm/security/advisories/GHSA-h3rc-j82p-2c3h",
"https://github.com/vllm-project/vllm/pull/60022",
"https://github.com/vllm-project/vllm/commit/710ac56e691d4713feca50a43e6c440f07d373fd",
"https://github.com/vllm-project/vllm/releases/tag/v0.32.0"
],
"provider_metadata": {
"adp": [
{
"title": "CISA ADP Vulnrichment",
"metrics": [
{
"other": {
"type": "ssvc",
"content": {
"id": "CVE-2026-115915",
"role": "CISA Coordinator",
"options": [
{
"Exploitation": "none"
},
{
"Automatable": "no"
},
{
"Technical Impact": "total"
}
],
"version": "2.0.3",
"timestamp": "2026-10-26T19:31:21.498549Z"
}
}
}
],
"providerMetadata": {
"orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"shortName": "CISA-ADP",
"dateUpdated": "2026-10-26T19:35:10.423Z"
}
}
],
"cna": {
"orgId": "a0819718-46f1-4df5-94e2-005712e83aaa",
"shortName": "GitHub_M",
"dateUpdated": "2026-10-26T17:16:57.526Z"
}
}
},
"related_cves": [
{
"value": "CVE-2026-115915",
"evidence": "/cveMetadata/cveId"
}
],
"security_relevant": true,
"severity_evidence": "/containers/cna/metrics"
},
"source_id": "core-cve",
"document_id": 338255,
"published_at": "2026-10-26T17:16:06.387+00:00"
}