UnratedFix available
libgd2 — security advisory
Multiple buffer overflows in the gd graphics library (libgd) 2.0.21 and earlier may allow remote attackers to execute arbitrary code via malformed image files that trigger the overflows due to improper calls to the gdMalloc function, a different set of vulnerabilities than CVE-2004-0990.
- Products
- libgd2
- Affected versions
- Not specified
- Fixed versions
- 2.0.33-1.1
- CVEs
- CVE-2004-0941
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 14:23 UTC · Revision 1
Source evidence
Multiple buffer overflows in the gd graphics library (libgd) 2.0.21 and earlier may allow remote attackers to execute arbitrary code via malformed image files that trigger the overflows due to improper calls to the gdMalloc function, a different set of vulnerabilities than CVE-2004-0990.
osv:DEBIAN-CVE-2004-0941
libgd2
Fixed versions: 2.0.33-1.1
libgd2
Fixed versions: 2.0.33-1.1
libgd2
Fixed versions: 2.0.33-1.1
Complete source record
{
"id": "b041c6a4c95f4aa9faaf715d52d6b77ce4edd1715aebfd605c9a47986a05f1b7",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2004-0941",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2004-0941",
"summary": "Multiple buffer overflows in the gd graphics library (libgd) 2.0.21 and earlier may allow remote attackers to execute arbitrary code via malformed image files that trigger the overflows due to improper calls to the gdMalloc function, a different set of vulnerabilities than CVE-2004-0990.",
"evidence": "osv:DEBIAN-CVE-2004-0941",
"products": [
{
"name": {
"value": "libgd2",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.0.33-1.1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libgd2",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.0.33-1.1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libgd2",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.0.33-1.1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2004-0941",
"aliases": [
"DEBIAN-CVE-2004-0941"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.33-1.1"
}
]
}
],
"package": {
"name": "libgd2",
"purl": "pkg:deb/debian/libgd2?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2004-0941.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.33-1.1"
}
]
}
],
"package": {
"name": "libgd2",
"purl": "pkg:deb/debian/libgd2?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2004-0941.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.33-1.1"
}
]
}
],
"package": {
"name": "libgd2",
"purl": "pkg:deb/debian/libgd2?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2004-0941.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-21T15:47:24.316802151Z",
"provider": "osv",
"upstream": [
"CVE-2004-0941"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2004-0941"
]
},
"related_cves": [
{
"value": "CVE-2004-0941",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 393839,
"published_at": "2005-02-09T05:00:00+00:00"
}