nagvis — security advisory
A vulnerability was found in NagVis up to 1.9.33 and classified as problematic. This issue affects the function checkAuthCookie of the file share/server/core/classes/CoreLogonMultisite.php. The manipulation of the argument hash leads to incorrect type conversion. The attack may be initiated remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. Upgrading to version 1.9.34 is able to address this issue. The identifier of the patch is 7574fd8a2903282c2e0d1feef5c4876763db21d5. It is recommended to upgrade the affected component. The identifier VDB-213557 was assigned to this vulnerability.
- Products
- nagvis
- Affected versions
- Not specified
- Fixed versions
- 1:1.9.34-1
- CVEs
- CVE-2022-3979
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:58 UTC · Revision 1
Source evidence
A vulnerability was found in NagVis up to 1.9.33 and classified as problematic. This issue affects the function checkAuthCookie of the file share/server/core/classes/CoreLogonMultisite.php. The manipulation of the argument hash leads to incorrect type conversion. The attack may be initiated remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. Upgrading to version 1.9.34 is able to address this issue. The identifier of the patch is 7574fd8a2903282c2e0d1feef5c4876763db21d5. It is recommended to upgrade the affected component. The identifier VDB-213557 was assigned to this vulnerability.
osv:DEBIAN-CVE-2022-3979
nagvis
Fixed versions: 1:1.9.34-1
nagvis
Fixed versions: 1:1.9.34-1
nagvis
Fixed versions: 1:1.9.34-1
Complete source record
{
"id": "a10892b1d3ae14b2b2835cee09c4235d6c701bf6785cf563eaaaf01bfcae9b14",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-3979",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-3979",
"summary": "A vulnerability was found in NagVis up to 1.9.33 and classified as problematic. This issue affects the function checkAuthCookie of the file share/server/core/classes/CoreLogonMultisite.php. The manipulation of the argument hash leads to incorrect type conversion. The attack may be initiated remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. Upgrading to version 1.9.34 is able to address this issue. The identifier of the patch is 7574fd8a2903282c2e0d1feef5c4876763db21d5. It is recommended to upgrade the affected component. The identifier VDB-213557 was assigned to this vulnerability.",
"evidence": "osv:DEBIAN-CVE-2022-3979",
"products": [
{
"name": {
"value": "nagvis",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:1.9.34-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "nagvis",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:1.9.34-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "nagvis",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:1.9.34-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-3979",
"aliases": [
"DEBIAN-CVE-2022-3979"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:1.9.34-1"
}
]
}
],
"package": {
"name": "nagvis",
"purl": "pkg:deb/debian/nagvis?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-3979.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:1.9.34-1"
}
]
}
],
"package": {
"name": "nagvis",
"purl": "pkg:deb/debian/nagvis?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-3979.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:1.9.34-1"
}
]
}
],
"package": {
"name": "nagvis",
"purl": "pkg:deb/debian/nagvis?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-3979.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:41.179277259Z",
"provider": "osv",
"upstream": [
"CVE-2022-3979"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-3979"
]
},
"related_cves": [
{
"value": "CVE-2022-3979",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 323969,
"published_at": "2022-11-13T23:15:09.81+00:00"
}