Medium
WordPress Advanced Post Block - Post Grid for WordPress block editor plugin <= 2.5.1 - Cross Site Scripting (XSS) vulnerability
Type: advisorySources: Official CVE List
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Advanced Post Block - Post Grid for WordPress block editor advanced-post-block allows Stored XSS.This issue affects Advanced Post Block - Post Grid for WordPress block editor: from n/a through 2.5.1.
- Products
- Advanced Post Block - Post Grid for WordPress block editor
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-115955
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 08:58 UTC · Revision 1
Source evidence
WordPress Advanced Post Block - Post Grid for WordPress block editor plugin <= 2.5.1 - Cross Site Scripting (XSS) vulnerability
core-cve · Original sourcePublished 26 Oct 2026, 10:35 UTC
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Advanced Post Block - Post Grid for WordPress block editor advanced-post-block allows Stored XSS.This issue affects Advanced Post Block - Post Grid for WordPress block editor: from n/a through 2.5.1.
cve:CVE-2026-115955
Advanced Post Block - Post Grid for WordPress block editor
Fixed versions: Not specified
Complete source record
{
"id": "6aacd7ff3d06bcc1116caefb14b6e9b4827162cd67e8312fd5fc624cf55d15bd",
"url": "https://www.cve.org/CVERecord?id=CVE-2026-115955",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WordPress Advanced Post Block - Post Grid for WordPress block editor plugin <= 2.5.1 - Cross Site Scripting (XSS) vulnerability",
"summary": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Advanced Post Block - Post Grid for WordPress block editor advanced-post-block allows Stored XSS.This issue affects Advanced Post Block - Post Grid for WordPress block editor: from n/a through 2.5.1.",
"evidence": "cve:CVE-2026-115955",
"products": [
{
"name": {
"value": "Advanced Post Block - Post Grid for WordPress block editor",
"evidence": "/containers/cna/affected/0/product"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "CVE-2026-115955",
"aliases": [
"CVE-2026-115955"
],
"metrics": [
{
"format": "CVSS",
"cvssV3_1": {
"scope": "CHANGED",
"version": "3.1",
"baseScore": 6.5,
"attackVector": "NETWORK",
"baseSeverity": "MEDIUM",
"vectorString": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L",
"integrityImpact": "LOW",
"userInteraction": "REQUIRED",
"attackComplexity": "LOW",
"availabilityImpact": "LOW",
"privilegesRequired": "LOW",
"confidentialityImpact": "LOW"
},
"scenarios": [
{
"lang": "en",
"value": "GENERAL"
}
]
}
],
"affected": [
{
"vendor": "bPlugins",
"product": "Advanced Post Block - Post Grid for WordPress block editor",
"versions": [
{
"status": "affected",
"changes": [
{
"at": "2.5.2",
"status": "unaffected"
}
],
"version": "0",
"versionType": "custom",
"lessThanOrEqual": "2.5.1"
}
],
"packageName": "advanced-post-block",
"collectionURL": "https://wordpress.org/plugins",
"defaultStatus": "unaffected"
}
],
"modified": "2026-10-26T12:54:33.290Z",
"provider": "cve",
"references": [
"https://patchstack.com/database/wordpress/plugin/advanced-post-block/vulnerability/wordpress-advanced-post-block-post-grid-for-wordpress-block-editor-plugin-2-5-1-cross-site-scripting-xss-vulnerability?_s_id=cve"
],
"provider_metadata": {
"adp": [
{
"title": "CISA ADP Vulnrichment",
"metrics": [
{
"other": {
"type": "ssvc",
"content": {
"id": "CVE-2026-115955",
"role": "CISA Coordinator",
"options": [
{
"Exploitation": "none"
},
{
"Automatable": "no"
},
{
"Technical Impact": "partial"
}
],
"version": "2.0.3",
"timestamp": "2026-10-26T12:44:47.182156Z"
}
}
}
],
"providerMetadata": {
"orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"shortName": "CISA-ADP",
"dateUpdated": "2026-10-26T12:54:33.290Z"
}
}
],
"cna": {
"orgId": "21595511-bba5-4825-b968-b78d1f9984a3",
"shortName": "Patchstack",
"dateUpdated": "2026-10-26T10:36:04.744Z"
}
}
},
"related_cves": [
{
"value": "CVE-2026-115955",
"evidence": "/cveMetadata/cveId"
}
],
"security_relevant": true,
"severity_evidence": "/containers/cna/metrics"
},
"source_id": "core-cve",
"document_id": 307245,
"published_at": "2026-10-26T10:35:04.514+00:00"
}