Stirling-Tools Stirling-PDF Markdown-to-PDF cross site scripting
A vulnerability was found in Stirling-Tools Stirling-PDF up to 0.28.3. It has been declared as problematic. This vulnerability affects unknown code of the component Markdown-to-PDF. The manipulation leads to cross site scripting. The attack can be initiated remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 0.29.0 is able to address this issue. It is recommended to upgrade the affected component. The vendor explains that "this functionality was removed in 0.29.0 already" and "we plan to re-add at later date with issue resolved".
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-9075
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 13:52 UTC · Revision 1
Source evidence
Stirling-Tools Stirling-PDF Markdown-to-PDF cross site scripting
core-osv · Original sourcePublished 21 Sept 2024, 23:00 UTC
A vulnerability was found in Stirling-Tools Stirling-PDF up to 0.28.3. It has been declared as problematic. This vulnerability affects unknown code of the component Markdown-to-PDF. The manipulation leads to cross site scripting. The attack can be initiated remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 0.29.0 is able to address this issue. It is recommended to upgrade the affected component. The vendor explains that "this functionality was removed in 0.29.0 already" and "we plan to re-add at later date with issue resolved".
osv:CVE-2024-9075
Complete source record
{
"id": "69dbc3d9611e84b758618ce875aaecb18a697bb11acd5d9e488e6e6d475d9f81",
"url": "https://osv.dev/vulnerability/CVE-2024-9075",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Stirling-Tools Stirling-PDF Markdown-to-PDF cross site scripting",
"summary": "A vulnerability was found in Stirling-Tools Stirling-PDF up to 0.28.3. It has been declared as problematic. This vulnerability affects unknown code of the component Markdown-to-PDF. The manipulation leads to cross site scripting. The attack can be initiated remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 0.29.0 is able to address this issue. It is recommended to upgrade the affected component. The vendor explains that \"this functionality was removed in 0.29.0 already\" and \"we plan to re-add at later date with issue resolved\".",
"evidence": "osv:CVE-2024-9075",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2024-9075",
"aliases": [
"CVE-2024-9075"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/stirling-tools/stirling-pdf",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "d389b5e2f339f436927c9f5af2f0d40123587fa6"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:stirlingpdf:stirling_pdf:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.29.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v0.28.3",
"v0.28.2",
"v0.28.1",
"v0.28.0",
"v0.27.0",
"v0.26.1",
"v0.26.0",
"v0.25.3",
"v0.25.2",
"v0.25.1",
"v0.25.0",
"v0.24.6",
"v0.24.5",
"v0.24.3",
"v0.24.4",
"v0.24.1",
"v0.24.2",
"v0.24.0",
"v0.22.8",
"v0.23.1",
"v0.23.0",
"v0.22.7",
"v0.22.6",
"v0.22.5",
"v0.22.4",
"v0.22.3",
"v0.22.2",
"v0.22.1",
"v0.22.0",
"v0.21.0",
"v0.20.2",
"v0.20.1",
"v0.20.0",
"v0.19.1",
"v0.19.0",
"v0.18.1",
"v0.18.0",
"v0.17.2",
"v0.17.1",
"v0.17.0",
"v0.16.1",
"v0.16.0",
"v0.15.1",
"v0.15.0",
"v0.14.5",
"v0.14.4",
"v0.14.3",
"v0.14.2",
"v0.14.1",
"v0.14.0",
"v0.13.1",
"v0.13.0",
"0.13.0",
"v0.12.2",
"v0.12.1",
"v0.12.0",
"v0.10.3",
"v0.10.2",
"v0.10.1",
"v0.10.0",
"v0.9.1",
"v0.9.0",
"v0.8.3",
"v0.8.2",
"v0.8.1",
"v0.8.0",
"v0.7.0",
"v0.6.0",
"v0.5.0",
"v0.4.8",
"v0.4.7",
"v0.4.6",
"v0.4.5",
"v0.4.4",
"v0.4.3",
"v0.4.2",
"v0.4.0",
"v0.3.4",
"v0.3.3",
"v0.3.2",
"v0.3.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-9075.json"
}
}
],
"modified": "2026-10-28T02:30:50.909136423Z",
"provider": "osv",
"references": [
"https://drive.google.com/file/d/1J4TnzgzKOEvMck3kpaFuR6zfSVt7YgKu/view?usp=sharing",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/9xxx/CVE-2024-9075.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-9075",
"https://vuldb.com/?id.278242",
"https://vuldb.com/?submit.406335",
"https://vuldb.com/?ctiid.278242"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "VulDB",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "0.28.0"
},
{
"last_affected": "0.28.0"
},
{
"introduced": "0.28.1"
},
{
"last_affected": "0.28.1"
},
{
"introduced": "0.28.2"
},
{
"last_affected": "0.28.2"
},
{
"introduced": "0.28.3"
},
{
"last_affected": "0.28.3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/9xxx/CVE-2024-9075.json"
}
},
"related_cves": [
{
"value": "CVE-2024-9075",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 519526,
"published_at": "2024-09-21T23:00:06.683+00:00"
}