libxml2 — security advisory
Uncontrolled recursion in XPath evaluation in libxml2 up to and including version 2.9.14 allows a local attacker to cause a stack overflow via crafted expressions. XPath processing functions `xmlXPathRunEval`, `xmlXPathCtxtCompile`, and `xmlXPathEvalExpr` were resetting recursion depth to zero before making potentially recursive calls. When such functions were called recursively this could allow for uncontrolled recursion and lead to a stack overflow. These functions now preserve recursion depth across recursive calls, allowing recursion depth to be controlled.
- Products
- libxml2
- Affected versions
- 2.12.7+dfsg+really2.9.14-2.1, 2.12.7+dfsg+really2.9.14-2.1+deb13u1, 2.13.1+dfsg-0exp1, 2.13.3+dfsg-0exp1, 2.13.3+dfsg-0exp2, 2.14.1+dfsg-0exp1, 2.14.2+dfsg-0exp1, 2.14.3+dfsg-0exp1, 2.14.3+dfsg-0exp2, 2.14.3+dfsg-0exp3, 2.14.4+dfsg-0exp1, 2.14.5+dfsg-0exp1, 2.14.5+dfsg-0exp2, 2.9.14+dfsg-1.2, 2.9.14+dfsg-1.3~deb12u1, 2.9.14+dfsg-1.3~deb12u2, 2.9.14+dfsg-1.3~deb12u3, 2.9.14+dfsg-1.3~deb12u4
- Fixed versions
- 2.12.7+dfsg+really2.9.14-2.1+deb13u2, 2.14.5+dfsg-0.1, 2.9.14+dfsg-1.3~deb12u5
- CVEs
- CVE-2025-9714
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 22:33 UTC · Revision 1
Source evidence
Uncontrolled recursion in XPath evaluation in libxml2 up to and including version 2.9.14 allows a local attacker to cause a stack overflow via crafted expressions. XPath processing functions `xmlXPathRunEval`, `xmlXPathCtxtCompile`, and `xmlXPathEvalExpr` were resetting recursion depth to zero before making potentially recursive calls. When such functions were called recursively this could allow for uncontrolled recursion and lead to a stack overflow. These functions now preserve recursion depth across recursive calls, allowing recursion depth to be controlled.
osv:DEBIAN-CVE-2025-9714
libxml2
Fixed versions: 2.9.14+dfsg-1.3~deb12u5
libxml2
Fixed versions: 2.12.7+dfsg+really2.9.14-2.1+deb13u2
libxml2
Fixed versions: 2.14.5+dfsg-0.1
Complete source record
{
"id": "8cc3258f8d798b4544758497121b3fe562fe8d5cde740a7424913b27415ef865",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2025-9714",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2025-9714",
"summary": "Uncontrolled recursion in XPath evaluation in libxml2 up to and including version 2.9.14 allows a local attacker to cause a stack overflow via crafted expressions. XPath processing functions `xmlXPathRunEval`, `xmlXPathCtxtCompile`, and `xmlXPathEvalExpr` were resetting recursion depth to zero before making potentially recursive calls. When such functions were called recursively this could allow for uncontrolled recursion and lead to a stack overflow. These functions now preserve recursion depth across recursive calls, allowing recursion depth to be controlled.",
"evidence": "osv:DEBIAN-CVE-2025-9714",
"products": [
{
"name": {
"value": "libxml2",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.9.14+dfsg-1.3~deb12u5",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "2.9.14+dfsg-1.2",
"evidence": "/affected/0/versions"
},
{
"value": "2.9.14+dfsg-1.3~deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "2.9.14+dfsg-1.3~deb12u2",
"evidence": "/affected/0/versions"
},
{
"value": "2.9.14+dfsg-1.3~deb12u3",
"evidence": "/affected/0/versions"
},
{
"value": "2.9.14+dfsg-1.3~deb12u4",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "libxml2",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.12.7+dfsg+really2.9.14-2.1+deb13u2",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "2.12.7+dfsg+really2.9.14-2.1",
"evidence": "/affected/1/versions"
},
{
"value": "2.12.7+dfsg+really2.9.14-2.1+deb13u1",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "libxml2",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.14.5+dfsg-0.1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "2.12.7+dfsg+really2.9.14-2.1",
"evidence": "/affected/2/versions"
},
{
"value": "2.13.1+dfsg-0exp1",
"evidence": "/affected/2/versions"
},
{
"value": "2.13.3+dfsg-0exp1",
"evidence": "/affected/2/versions"
},
{
"value": "2.13.3+dfsg-0exp2",
"evidence": "/affected/2/versions"
},
{
"value": "2.14.1+dfsg-0exp1",
"evidence": "/affected/2/versions"
},
{
"value": "2.14.2+dfsg-0exp1",
"evidence": "/affected/2/versions"
},
{
"value": "2.14.3+dfsg-0exp1",
"evidence": "/affected/2/versions"
},
{
"value": "2.14.3+dfsg-0exp2",
"evidence": "/affected/2/versions"
},
{
"value": "2.14.3+dfsg-0exp3",
"evidence": "/affected/2/versions"
},
{
"value": "2.14.4+dfsg-0exp1",
"evidence": "/affected/2/versions"
},
{
"value": "2.14.5+dfsg-0exp1",
"evidence": "/affected/2/versions"
},
{
"value": "2.14.5+dfsg-0exp2",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2025-9714",
"aliases": [
"DEBIAN-CVE-2025-9714"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.9.14+dfsg-1.3~deb12u5"
}
]
}
],
"package": {
"name": "libxml2",
"purl": "pkg:deb/debian/libxml2?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"2.9.14+dfsg-1.2",
"2.9.14+dfsg-1.3~deb12u1",
"2.9.14+dfsg-1.3~deb12u2",
"2.9.14+dfsg-1.3~deb12u3",
"2.9.14+dfsg-1.3~deb12u4"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-9714.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.12.7+dfsg+really2.9.14-2.1+deb13u2"
}
]
}
],
"package": {
"name": "libxml2",
"purl": "pkg:deb/debian/libxml2?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"2.12.7+dfsg+really2.9.14-2.1",
"2.12.7+dfsg+really2.9.14-2.1+deb13u1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-9714.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.14.5+dfsg-0.1"
}
]
}
],
"package": {
"name": "libxml2",
"purl": "pkg:deb/debian/libxml2?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"2.12.7+dfsg+really2.9.14-2.1",
"2.13.1+dfsg-0exp1",
"2.13.3+dfsg-0exp1",
"2.13.3+dfsg-0exp2",
"2.14.1+dfsg-0exp1",
"2.14.2+dfsg-0exp1",
"2.14.3+dfsg-0exp1",
"2.14.3+dfsg-0exp2",
"2.14.3+dfsg-0exp3",
"2.14.4+dfsg-0exp1",
"2.14.5+dfsg-0exp1",
"2.14.5+dfsg-0exp2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-9714.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T17:47:24.377788313Z",
"provider": "osv",
"upstream": [
"CVE-2025-9714"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2025-9714"
]
},
"related_cves": [
{
"value": "CVE-2025-9714",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 416750,
"published_at": "2025-09-10T19:15:42.707+00:00"
}