pyenv — security advisory
Pyenv provides simple Python version management. Prior to 2.8.0, is_version_safe() in libexec/pyenv-version-file-read accepts shell glob metacharacters in .python-version values, and unquoted PYENV_VERSION expansion in libexec/pyenv-version-name, libexec/pyenv-which, libexec/pyenv-prefix, libexec/pyenv-local, libexec/pyenv-global, libexec/pyenv-version, and libexec/pyenv-versions pathname-expands the value against the current directory, allowing a matching attacker-controlled file to silently select a different installed interpreter or version. This issue is fixed in version 2.8.0.
- Products
- pyenv
- Affected versions
- 2.5.4-1build1, 2.6.28-1, 2.6.8-1, 2.7.1-1
- Fixed versions
- Not specified
- CVEs
- CVE-2026-68939
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 02:50 UTC · Revision 1
Source evidence
Pyenv provides simple Python version management. Prior to 2.8.0, is_version_safe() in libexec/pyenv-version-file-read accepts shell glob metacharacters in .python-version values, and unquoted PYENV_VERSION expansion in libexec/pyenv-version-name, libexec/pyenv-which, libexec/pyenv-prefix, libexec/pyenv-local, libexec/pyenv-global, libexec/pyenv-version, and libexec/pyenv-versions pathname-expands the value against the current directory, allowing a matching attacker-controlled file to silently select a different installed interpreter or version. This issue is fixed in version 2.8.0.
osv:UBUNTU-CVE-2026-68939
pyenv
Fixed versions: Not specified
pyenv
Fixed versions: Not specified
Complete source record
{
"id": "d92978c030c30c0a2d49ddab83db7476db797ace1edb9e221bfe1f88149bfbe7",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2026-68939",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2026-68939",
"summary": "Pyenv provides simple Python version management. Prior to 2.8.0, is_version_safe() in libexec/pyenv-version-file-read accepts shell glob metacharacters in .python-version values, and unquoted PYENV_VERSION expansion in libexec/pyenv-version-name, libexec/pyenv-which, libexec/pyenv-prefix, libexec/pyenv-local, libexec/pyenv-global, libexec/pyenv-version, and libexec/pyenv-versions pathname-expands the value against the current directory, allowing a matching attacker-controlled file to silently select a different installed interpreter or version. This issue is fixed in version 2.8.0.",
"evidence": "osv:UBUNTU-CVE-2026-68939",
"products": [
{
"name": {
"value": "pyenv",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.6.8-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.6.28-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.7.1-1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "pyenv",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.5.4-1build1",
"evidence": "/affected/1/versions"
},
{
"value": "2.6.8-1",
"evidence": "/affected/1/versions"
}
]
}
],
"severity": "low",
"structured": {
"id": "UBUNTU-CVE-2026-68939",
"aliases": [
"UBUNTU-CVE-2026-68939"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "pyenv",
"purl": "pkg:deb/ubuntu/pyenv?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"2.6.8-1",
"2.6.28-1",
"2.7.1-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-68939.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "pyenv",
"binary_version": "2.7.1-1"
},
{
"binary_name": "pyenv-runtime",
"binary_version": "2.7.1-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "pyenv",
"purl": "pkg:deb/ubuntu/pyenv?arch=source&distro=resolute",
"ecosystem": "Ubuntu:26.04:LTS"
},
"versions": [
"2.5.4-1build1",
"2.6.8-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-68939.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "pyenv",
"binary_version": "2.6.8-1"
},
{
"binary_name": "pyenv-runtime",
"binary_version": "2.6.8-1"
}
]
}
}
],
"modified": "2026-10-17T12:59:23.794334425Z",
"provider": "osv",
"upstream": [
"CVE-2026-68939"
],
"references": [
"https://ubuntu.com/security/CVE-2026-68939",
"https://www.cve.org/CVERecord?id=CVE-2026-68939"
]
},
"related_cves": [
{
"value": "CVE-2026-68939",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 359640,
"published_at": "2026-08-18T15:17:00+00:00"
}