Medium
GLPI Vulnerable to Unauthenticated Stored XSS on the Inventory page
Type: advisorySources: OSV
GLPI is a free asset and IT management software package. Starting in version 10.0.0 and prior to version 10.0.21, an unauthenticated user can store an XSS payload through the inventory endpoint. Users should upgrade to 10.0.21 to receive a patch.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-59935
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 04:10 UTC · Revision 1
Source evidence
GLPI Vulnerable to Unauthenticated Stored XSS on the Inventory page
core-osv · Original sourcePublished 16 Dec 2025, 16:34 UTC
GLPI is a free asset and IT management software package. Starting in version 10.0.0 and prior to version 10.0.21, an unauthenticated user can store an XSS payload through the inventory endpoint. Users should upgrade to 10.0.21 to receive a patch.
osv:CVE-2025-59935
Complete source record
{
"id": "477600307e7e2466f54bab336b6a0f2ba11911311a9bcf600fe883223c1153d5",
"url": "https://osv.dev/vulnerability/CVE-2025-59935",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "GLPI Vulnerable to Unauthenticated Stored XSS on the Inventory page",
"summary": "GLPI is a free asset and IT management software package. Starting in version 10.0.0 and prior to version 10.0.21, an unauthenticated user can store an XSS payload through the inventory endpoint. Users should upgrade to 10.0.21 to receive a patch.",
"evidence": "osv:CVE-2025-59935",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-59935",
"aliases": [
"CVE-2025-59935",
"GHSA-j8vv-9f8m-r7jx"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/glpi-project/glpi",
"type": "GIT",
"events": [
{
"introduced": "815997021a5df4feb7077a12f6f52769e9bd3459"
},
{
"fixed": "c6141a2ae3d248ddc979f15d691fb4eec3f75edc"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "10.0.0"
},
{
"fixed": "10.0.21"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "10.0.0"
},
{
"fixed": "10.0.21"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"10.0.20",
"10.0.19",
"10.0.18",
"10.0.17",
"10.0.16",
"10.0.15",
"10.0.14",
"10.0.13",
"10.0.12",
"10.0.11",
"10.0.10",
"10.0.9",
"10.0.8",
"10.0.7",
"10.0.6",
"10.0.5",
"10.0.4",
"10.0.3",
"10.0.2",
"10.0.1",
"10.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-59935.json"
}
}
],
"modified": "2026-10-28T02:30:25.678269435Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/59xxx/CVE-2025-59935.json",
"https://github.com/glpi-project/glpi/security/advisories/GHSA-j8vv-9f8m-r7jx",
"https://nvd.nist.gov/vuln/detail/CVE-2025-59935"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/59xxx/CVE-2025-59935.json"
}
},
"related_cves": [
{
"value": "CVE-2025-59935",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 492407,
"published_at": "2025-12-16T16:34:46.251+00:00"
}