High
Apache Kyuubi: Unauthorized directory access due to missing path normalization
Type: advisorySources: OSV
Any client who can access to Apache Kyuubi Server via Kyuubi frontend protocols can bypass server-side config kyuubi.session.local.dir.allow.list and use local files which are not listed in the config. This issue affects Apache Kyuubi: from 1.6.0 through 1.10.2. Users are recommended to upgrade to version 1.10.3 or upper, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-66518
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 14:38 UTC · Revision 1
Source evidence
Apache Kyuubi: Unauthorized directory access due to missing path normalization
core-osv · Original sourcePublished 5 Jan 2026, 08:46 UTC
Any client who can access to Apache Kyuubi Server via Kyuubi frontend protocols can bypass server-side config kyuubi.session.local.dir.allow.list and use local files which are not listed in the config. This issue affects Apache Kyuubi: from 1.6.0 through 1.10.2. Users are recommended to upgrade to version 1.10.3 or upper, which fixes the issue.
osv:CVE-2025-66518
Complete source record
{
"id": "fcd0265daf11f9e270f91fc693524904b7f68a1ebb54170ff3552b0dc3d41302",
"url": "https://osv.dev/vulnerability/CVE-2025-66518",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Kyuubi: Unauthorized directory access due to missing path normalization",
"summary": "Any client who can access to Apache Kyuubi Server via Kyuubi frontend protocols can bypass server-side config kyuubi.session.local.dir.allow.list and use local files which are not listed in the config. This issue affects Apache Kyuubi: from 1.6.0 through 1.10.2. Users are recommended to upgrade to version 1.10.3 or upper, which fixes the issue.",
"evidence": "osv:CVE-2025-66518",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2025-66518",
"aliases": [
"CVE-2025-66518",
"GHSA-f8r6-6222-9pvc"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/kyuubi",
"type": "GIT",
"events": [
{
"introduced": "83118a514612a85b2df35a9aa3d42d75fd27aa36"
},
{
"fixed": "3b8105221a482f6f5665207d752640b41961ceac"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:kyuubi:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "1.6.0"
},
{
"fixed": "1.10.3"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-66518.json"
}
}
],
"modified": "2026-10-28T02:30:29.570889612Z",
"provider": "osv",
"references": [
"https://repo.maven.apache.org/maven2",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/66xxx/CVE-2025-66518.json",
"https://lists.apache.org/thread/xp460bwbyzdhho34ljd4nchyt2fmhodl",
"https://nvd.nist.gov/vuln/detail/CVE-2025-66518"
],
"provider_metadata": {
"cwe_ids": [
"CWE-27"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "1.6.0"
},
{
"last_affected": "1.10.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/66xxx/CVE-2025-66518.json"
}
},
"related_cves": [
{
"value": "CVE-2025-66518",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 496442,
"published_at": "2026-01-05T08:46:27.649+00:00"
}