jmespath.php has CompilerRuntime code injection via unescaped function names
jmespath.php allows users to use JMESPath, software for declaratively specifying how to extract elements from a JSON document, in PHP applications with PHP data structures. Versions prior to 2.9.1 can generate and execute attacker-controlled PHP code when `JmesPath\CompilerRuntime` is used with an attacker-controlled JMESPath expression. The compiler emits parsed JMESPath function names into generated PHP source without sufficient escaping. A crafted expression can cause the generated cache file to contain executable attacker-controlled PHP, which is then loaded by the compiler runtime. The issue is patched in `2.9.1` and later. As a workaround, disable `JP_PHP_COMPILE` and do not use `JmesPath\CompilerRuntime` with attacker-controlled expressions. Use the default `AstRuntime` for untrusted expressions. Applications that must continue accepting untrusted JMESPath expressions before upgrading should ensure those expressions are never evaluated by the compiler runtime.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-54133
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 8 Nov 2026, 00:31 UTC · Revision 1
Source evidence
jmespath.php has CompilerRuntime code injection via unescaped function names
core-osv · Original sourcePublished 12 Jun 2026, 13:56 UTC
jmespath.php allows users to use JMESPath, software for declaratively specifying how to extract elements from a JSON document, in PHP applications with PHP data structures. Versions prior to 2.9.1 can generate and execute attacker-controlled PHP code when `JmesPath\CompilerRuntime` is used with an attacker-controlled JMESPath expression. The compiler emits parsed JMESPath function names into generated PHP source without sufficient escaping. A crafted expression can cause the generated cache file to contain executable attacker-controlled PHP, which is then loaded by the compiler runtime. The issue is patched in `2.9.1` and later. As a workaround, disable `JP_PHP_COMPILE` and do not use `JmesPath\CompilerRuntime` with attacker-controlled expressions. Use the default `AstRuntime` for untrusted expressions. Applications that must continue accepting untrusted JMESPath expressions before upgrading should ensure those expressions are never evaluated by the compiler runtime.
osv:CVE-2026-54133
Complete source record
{
"id": "2a2331668026688e8963930af5d52986bdbbf237a0728f368d7b52fbf6a71518",
"url": "https://osv.dev/vulnerability/CVE-2026-54133",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "jmespath.php has CompilerRuntime code injection via unescaped function names",
"summary": "jmespath.php allows users to use JMESPath, software for declaratively specifying how to extract elements from a JSON document, in PHP applications with PHP data structures. Versions prior to 2.9.1 can generate and execute attacker-controlled PHP code when `JmesPath\\CompilerRuntime` is used with an attacker-controlled JMESPath expression. The compiler emits parsed JMESPath function names into generated PHP source without sufficient escaping. A crafted expression can cause the generated cache file to contain executable attacker-controlled PHP, which is then loaded by the compiler runtime. The issue is patched in `2.9.1` and later. As a workaround, disable `JP_PHP_COMPILE` and do not use `JmesPath\\CompilerRuntime` with attacker-controlled expressions. Use the default `AstRuntime` for untrusted expressions. Applications that must continue accepting untrusted JMESPath expressions before upgrading should ensure those expressions are never evaluated by the compiler runtime.",
"evidence": "osv:CVE-2026-54133",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2026-54133",
"aliases": [
"CVE-2026-54133",
"GHSA-pcw8-m77r-2528"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/jmespath/jmespath.php",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "9c208ba27ae7d90853c288b3795d6702eb251d34"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "2.9.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:jmespath:jmespath:*:*:*:*:*:php:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.9.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.9.0",
"2.8.0",
"2.7.0",
"2.6.1",
"2.6.0",
"2.5.0",
"2.4.0",
"2.3.0",
"2.2.0",
"2.1.0",
"2.0.0",
"1.1.1",
"1.1.0",
"1.0.0",
"0.4.0",
"0.3.0",
"0.2.0",
"0.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-54133.json"
}
}
],
"modified": "2026-10-28T02:30:52.182034897Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/54xxx/CVE-2026-54133.json",
"https://github.com/jmespath/jmespath.php/security/advisories/GHSA-pcw8-m77r-2528",
"https://nvd.nist.gov/vuln/detail/CVE-2026-54133"
],
"provider_metadata": {
"cwe_ids": [
"CWE-116",
"CWE-20",
"CWE-94"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/54xxx/CVE-2026-54133.json"
}
},
"related_cves": [
{
"value": "CVE-2026-54133",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 520991,
"published_at": "2026-06-12T13:56:37.874+00:00"
}