Skip to content
Heist/ feed
Back to feed
High

Deserialization of Untrusted Data in Codeigniter4

Type: advisorySources: OSV

CodeIgniter is an open source PHP full-stack web framework. Deserialization of Untrusted Data was found in the `old()` function in CodeIgniter4. Remote attackers may inject auto-loadable arbitrary objects with this vulnerability, and possibly execute existing PHP code on the server. We are aware of a working exploit, which can lead to SQL injection. Users are advised to upgrade to v4.1.6 or later. Users unable to upgrade as advised to not use the `old()` function and form_helper nor `RedirectResponse::withInput()` and `redirect()->withInput()`.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-21647
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 13:45 UTC · Revision 1

Source evidence

Deserialization of Untrusted Data in Codeigniter4

core-osv · Original source

Published 4 Jan 2022, 20:05 UTC

CodeIgniter is an open source PHP full-stack web framework. Deserialization of Untrusted Data was found in the `old()` function in CodeIgniter4. Remote attackers may inject auto-loadable arbitrary objects with this vulnerability, and possibly execute existing PHP code on the server. We are aware of a working exploit, which can lead to SQL injection. Users are advised to upgrade to v4.1.6 or later. Users unable to upgrade as advised to not use the `old()` function and form_helper nor `RedirectResponse::withInput()` and `redirect()->withInput()`.

osv:CVE-2022-21647
Complete source record
{
  "id": "db5c2cc6b29fdbc4af7a8e5f750b730af2d3941b03a893f0028ba062968b75b1",
  "url": "https://osv.dev/vulnerability/CVE-2022-21647",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Deserialization of Untrusted Data in Codeigniter4",
    "summary": "CodeIgniter is an open source PHP full-stack web framework. Deserialization of Untrusted Data was found in the `old()` function in CodeIgniter4. Remote attackers may inject auto-loadable arbitrary objects with this vulnerability, and possibly execute existing PHP code on the server. We are aware of a working exploit, which can lead to SQL injection. Users are advised to upgrade to v4.1.6 or later. Users unable to upgrade as advised to not use the `old()` function and form_helper nor `RedirectResponse::withInput()` and `redirect()->withInput()`.",
    "evidence": "osv:CVE-2022-21647",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2022-21647",
      "aliases": [
        "BIT-codeigniter-2022-21647",
        "CVE-2022-21647",
        "GHSA-w6jr-wj64-mc9x"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/codeigniter4/codeigniter4",
              "type": "GIT",
              "events": [
                {
                  "introduced": "47dbb16bb5e5784f45bf09a7380016f2d36f7c39"
                },
                {
                  "fixed": "6b2816c7fe7bef75da6be286a16800c4f5d9992d"
                },
                {
                  "fixed": "ce95ed5765256e2f09f3513e7d42790e0d6948f5"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:codeigniter:codeigniter:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "4.0.0"
                      },
                      {
                        "fixed": "4.1.6"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "ce95ed5765256e2f09f3513e7d42790e0d6948f5"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v4.1.5",
            "v4.1.4",
            "v4.1.3",
            "v4.1.2",
            "v4.1.1",
            "v4.1.0",
            "v4.0.5",
            "v4.0.3",
            "4.0.0",
            "v4.0.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-21647.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:35.939340091Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/21xxx/CVE-2022-21647.json",
        "https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-w6jr-wj64-mc9x",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-21647",
        "https://github.com/codeigniter4/CodeIgniter4/commit/ce95ed5765256e2f09f3513e7d42790e0d6948f5"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-502"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/21xxx/CVE-2022-21647.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-21647",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 503237,
  "published_at": "2022-01-04T20:05:11+00:00"
}