Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2019-17599

The quiz-master-next (aka Quiz And Survey Master) plugin before 6.3.5 for WordPress is affected by: Cross Site Scripting (XSS). The impact is: Allows an attacker to execute arbitrary HTML and JavaScript code via the from or till parameter (and/or the quiz_id parameter). The component is: admin/quiz-options-page.php. The attack vector is: When the Administrator is logged in, a reflected XSS may execute upon a click on a malicious URL.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2019-17599
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 10:46 UTC · Revision 1

Source evidence

CVE-2019-17599

core-osv · Original source

Published 13 Dec 2019, 14:15 UTC

The quiz-master-next (aka Quiz And Survey Master) plugin before 6.3.5 for WordPress is affected by: Cross Site Scripting (XSS). The impact is: Allows an attacker to execute arbitrary HTML and JavaScript code via the from or till parameter (and/or the quiz_id parameter). The component is: admin/quiz-options-page.php. The attack vector is: When the Administrator is logged in, a reflected XSS may execute upon a click on a malicious URL.

osv:CVE-2019-17599
Complete source record
{
  "id": "775f8082ee65d570e71d6088f55043d6dd0cb576dc422932097b804e9ff204d4",
  "url": "https://osv.dev/vulnerability/CVE-2019-17599",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2019-17599",
    "summary": "The quiz-master-next (aka Quiz And Survey Master) plugin before 6.3.5 for WordPress is affected by: Cross Site Scripting (XSS). The impact is: Allows an attacker to execute arbitrary HTML and JavaScript code via the from or till parameter (and/or the quiz_id parameter). The component is: admin/quiz-options-page.php. The attack vector is: When the Administrator is logged in, a reflected XSS may execute upon a click on a malicious URL.",
    "evidence": "osv:CVE-2019-17599",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2019-17599",
      "aliases": [
        "CVE-2019-17599"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/quizandsurveymaster/quiz_master_next",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2f3770ceba726073d2b316358fe7ade2278cf200"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:expresstech:quiz_and_survey_master:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "6.3.5"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "6.3.3",
            "6.3.2",
            "6.3.1",
            "6.2.1",
            "6.2.0",
            "6.1.2",
            "6.1.1",
            "6.1.0",
            "6.0.4",
            "6.0.3",
            "6.0.2",
            "6.0.1",
            "6.0",
            "5.3.2",
            "5.3.1",
            "5.3.0",
            "5.2.4",
            "5.2.3",
            "5.2.2",
            "5.2.1",
            "5.2.0",
            "5.1.7",
            "5.1.6",
            "5.1.5",
            "5.1.4",
            "5.1.3",
            "5.1.2",
            "5.1.1",
            "5.1.0",
            "5.0.7",
            "5.0.6",
            "5.0.5",
            "5.0.4",
            "5.0.3",
            "5.0.2",
            "5.0.1",
            "5.0.0",
            "4.7.10",
            "4.7.9",
            "4.7.8",
            "4.7.7",
            "4.7.6",
            "4.7.5",
            "4.7.4",
            "4.7.3",
            "4.7.2",
            "4.7.1",
            "4.7.0",
            "4.6.7",
            "4.6.6",
            "4.6.5",
            "4.6.4",
            "4.6.3",
            "4.6.2",
            "4.6.1",
            "4.6.0",
            "4.5.5",
            "4.5.4",
            "4.5.3",
            "4.5.2",
            "4.5.1",
            "4.5.0",
            "4.4.4",
            "4.4.3",
            "4.4.2",
            "4.4.1",
            "4.4.0",
            "4.3.1",
            "4.3.0",
            "4.2.4",
            "4.2.3",
            "4.2.2",
            "4.2.1",
            "4.2.0",
            "4.1.0",
            "4.0.1",
            "4.0.0",
            "3.9.0",
            "3.8.2",
            "3.8.1",
            "3.7.1",
            "3.6.1",
            "3.5.2",
            "3.5.1",
            "3.4.1",
            "3.3.3"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-17599.json"
          }
        }
      ],
      "modified": "2026-10-20T10:51:37.937179287Z",
      "provider": "osv",
      "references": [
        "https://github.com/QuizandSurveyMaster/quiz_master_next/pull/796",
        "https://wordpress.org/plugins/quiz-master-next/#developers",
        "https://github.com/QuizandSurveyMaster/quiz_master_next/issues/795",
        "https://wpvulndb.com/vulnerabilities/9977"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2019-17599",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 382692,
  "published_at": "2019-12-13T14:15:12.297+00:00"
}