postfix — security advisory
Postfix through 3.8.5 allows SMTP smuggling unless configured with smtpd_data_restrictions=reject_unauth_pipelining and smtpd_discard_ehlo_keywords=chunking (or certain other options that exist in recent versions). Remote attackers can use a published exploitation technique to inject e-mail messages with a spoofed MAIL FROM address, allowing bypass of an SPF protection mechanism. This occurs because Postfix supports . but some other popular e-mail servers do not. To prevent attack variants (by always disallowing without ), a different solution is required, such as the smtpd_forbid_bare_newline=yes option with a Postfix minimum version of 3.5.23, 3.6.13, 3.7.9, 3.8.4, or 3.9.
- Products
- postfix
- Affected versions
- 3.7.5-2, 3.7.6-0+deb12u1, 3.7.6-0+deb12u2
- Fixed versions
- 3.7.9-0+deb12u1, 3.8.4-1
- CVEs
- CVE-2023-51764
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 11:07 UTC · Revision 1
Source evidence
Postfix through 3.8.5 allows SMTP smuggling unless configured with smtpd_data_restrictions=reject_unauth_pipelining and smtpd_discard_ehlo_keywords=chunking (or certain other options that exist in recent versions). Remote attackers can use a published exploitation technique to inject e-mail messages with a spoofed MAIL FROM address, allowing bypass of an SPF protection mechanism. This occurs because Postfix supports . but some other popular e-mail servers do not. To prevent attack variants (by always disallowing without ), a different solution is required, such as the smtpd_forbid_bare_newline=yes option with a Postfix minimum version of 3.5.23, 3.6.13, 3.7.9, 3.8.4, or 3.9.
osv:DEBIAN-CVE-2023-51764
postfix
Fixed versions: 3.7.9-0+deb12u1
postfix
Fixed versions: 3.8.4-1
postfix
Fixed versions: 3.8.4-1
Complete source record
{
"id": "8e05a744dcf54311af533569ca7b4d94d0738708a07e9478141a8081206bc02c",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-51764",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-51764",
"summary": "Postfix through 3.8.5 allows SMTP smuggling unless configured with smtpd_data_restrictions=reject_unauth_pipelining and smtpd_discard_ehlo_keywords=chunking (or certain other options that exist in recent versions). Remote attackers can use a published exploitation technique to inject e-mail messages with a spoofed MAIL FROM address, allowing bypass of an SPF protection mechanism. This occurs because Postfix supports . but some other popular e-mail servers do not. To prevent attack variants (by always disallowing without ), a different solution is required, such as the smtpd_forbid_bare_newline=yes option with a Postfix minimum version of 3.5.23, 3.6.13, 3.7.9, 3.8.4, or 3.9.",
"evidence": "osv:DEBIAN-CVE-2023-51764",
"products": [
{
"name": {
"value": "postfix",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.7.9-0+deb12u1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "3.7.5-2",
"evidence": "/affected/0/versions"
},
{
"value": "3.7.6-0+deb12u1",
"evidence": "/affected/0/versions"
},
{
"value": "3.7.6-0+deb12u2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "postfix",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.8.4-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "postfix",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.8.4-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2023-51764",
"aliases": [
"DEBIAN-CVE-2023-51764"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.7.9-0+deb12u1"
}
]
}
],
"package": {
"name": "postfix",
"purl": "pkg:deb/debian/postfix?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"3.7.5-2",
"3.7.6-0+deb12u1",
"3.7.6-0+deb12u2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-51764.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.8.4-1"
}
]
}
],
"package": {
"name": "postfix",
"purl": "pkg:deb/debian/postfix?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-51764.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.8.4-1"
}
]
}
],
"package": {
"name": "postfix",
"purl": "pkg:deb/debian/postfix?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-51764.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-09T09:47:26.419960809Z",
"provider": "osv",
"upstream": [
"CVE-2023-51764"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-51764"
]
},
"related_cves": [
{
"value": "CVE-2023-51764",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 111505,
"published_at": "2023-12-24T05:15:08.273+00:00"
}