Security advisory
All versions of Helm between Helm >=2.0.0 and < 2.12.2 contains a CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in The commands `helm fetch --untar` and `helm lint some.tgz` that can result when chart archive files are unpacked a file may be unpacked outside of the target directory. This attack appears to be exploitable via a victim must run a helm command on a specially crafted chart archive. This vulnerability appears to have been fixed in 2.12.2.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-1000008
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 04:23 UTC · Revision 1
Source evidence
All versions of Helm between Helm >=2.0.0 and < 2.12.2 contains a CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in The commands `helm fetch --untar` and `helm lint some.tgz` that can result when chart archive files are unpacked a file may be unpacked outside of the target directory. This attack appears to be exploitable via a victim must run a helm command on a specially crafted chart archive. This vulnerability appears to have been fixed in 2.12.2.
osv:CVE-2019-1000008
Complete source record
{
"id": "e1538085430795a9045494d00e01bbf271b17b06b5768700144bfe9e7de774a6",
"url": "https://osv.dev/vulnerability/CVE-2019-1000008",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-1000008",
"summary": "All versions of Helm between Helm >=2.0.0 and < 2.12.2 contains a CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in The commands `helm fetch --untar` and `helm lint some.tgz` that can result when chart archive files are unpacked a file may be unpacked outside of the target directory. This attack appears to be exploitable via a victim must run a helm command on a specially crafted chart archive. This vulnerability appears to have been fixed in 2.12.2.",
"evidence": "osv:CVE-2019-1000008",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2019-1000008",
"aliases": [
"CVE-2019-1000008",
"GHSA-xrxm-mvqm-r553",
"GO-2023-1948"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/helm/helm",
"type": "GIT",
"events": [
{
"introduced": "51bdad42756dfaf3234f53ef3d3cb6bcd94144c2"
},
{
"fixed": "7d2b0c73d734f6586ed222a567c5d103fed435be"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:helm:helm:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.12.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.12.1",
"v2.12.0-rc.2",
"v2.12.0",
"v2.10.0-rc.2",
"v2.10.0-rc.1",
"v2.8.0-rc.1",
"v2.7.0",
"v2.7.0-rc1",
"v2.6.0",
"v2.5.0",
"v2.4.0",
"v2.3.0",
"v2.2.0",
"v2.1.0",
"v2.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-1000008.json"
}
}
],
"modified": "2026-10-24T10:30:18.334604566Z",
"provider": "osv",
"references": [
"https://helm.sh/blog/helm-security-notice-2019/index.html"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2019-1000008",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 429748,
"published_at": "2019-02-04T21:29:00.91+00:00"
}