BuddyPress <= 12.4.1 - Authenticated (Subscriber+) Stored Cross-Site Scripting
The BuddyPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘display_name’ parameter in versions up to, and including, 12.4.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-4892
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 15:07 UTC · Revision 1
Source evidence
BuddyPress <= 12.4.1 - Authenticated (Subscriber+) Stored Cross-Site Scripting
core-osv · Original sourcePublished 12 Jun 2024, 01:55 UTC
The BuddyPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘display_name’ parameter in versions up to, and including, 12.4.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
osv:CVE-2024-4892
Complete source record
{
"id": "91e9faac467f96c5407d6b8eb2c20dc39eaba3eb62a8f1546fbbdf195214bac0",
"url": "https://osv.dev/vulnerability/CVE-2024-4892",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "BuddyPress <= 12.4.1 - Authenticated (Subscriber+) Stored Cross-Site Scripting",
"summary": "The BuddyPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘display_name’ parameter in versions up to, and including, 12.4.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
"evidence": "osv:CVE-2024-4892",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-4892",
"aliases": [
"CVE-2024-4892"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/buddypress/buddypress",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "1e162dfa4e9db6c9805f3d43c4694b372ec35c39"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:buddypress:buddypress:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "12.5.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-4892.json"
}
}
],
"modified": "2026-10-28T02:30:36.690684723Z",
"provider": "osv",
"references": [
"https://plugins.trac.wordpress.org/browser/buddypress/tags/12.4.1/bp-members/bp-members-blocks.php#L249",
"https://plugins.trac.wordpress.org/changeset/3100815/buddypress/trunk/bp-members/bp-members-blocks.php",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/113c154d-94a0-41da-a5ed-d9b2617e1c2c?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/4xxx/CVE-2024-4892.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-4892"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "Wordfence",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "12.5.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/4xxx/CVE-2024-4892.json"
}
},
"related_cves": [
{
"value": "CVE-2024-4892",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 503993,
"published_at": "2024-06-12T01:55:22.241+00:00"
}