Security advisory
The Dokan plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.0.8. This is due to missing or incorrect nonce validation on the handle_order_export() function. This makes it possible for unauthenticated attackers to trigger an order export via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2020-36748
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 07:35 UTC · Revision 1
Source evidence
The Dokan plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.0.8. This is due to missing or incorrect nonce validation on the handle_order_export() function. This makes it possible for unauthenticated attackers to trigger an order export via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
osv:CVE-2020-36748
Complete source record
{
"id": "9b1cc61ae54cd5b233f88dc041c9fe8b3913d868dc81329ec9128f902d50420a",
"url": "https://osv.dev/vulnerability/CVE-2020-36748",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2020-36748",
"summary": "The Dokan plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.0.8. This is due to missing or incorrect nonce validation on the handle_order_export() function. This makes it possible for unauthenticated attackers to trigger an order export via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.",
"evidence": "osv:CVE-2020-36748",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2020-36748",
"aliases": [
"CVE-2020-36748"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/getdokan/dokan",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "e672627e7fb322cb54f183b46161ca5fec959289"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:dokan:dokan:*:*:*:*:lite:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.0.9"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.5.6"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-36748.json"
}
}
],
"modified": "2026-10-24T10:30:55.453092772Z",
"provider": "osv",
"references": [
"https://www.wordfence.com/threat-intel/vulnerabilities/id/894c875a-078f-4c1f-83d2-4a6e4a309c3e?source=cve",
"https://plugins.trac.wordpress.org/changeset/2368433/dokan-lite/trunk/includes/Dashboard/Templates/Orders.php",
"https://blog.nintechnet.com/more-wordpress-plugins-and-themes-vulnerable-to-csrf-attacks/",
"https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-1/",
"https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-2/",
"https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-3/",
"https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-4/",
"https://blog.nintechnet.com/multiple-wordpress-plugins-fixed-csrf-vulnerabilities-part-5/",
"https://blog.nintechnet.com/25-wordpress-plugins-vulnerable-to-csrf-attacks/"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2020-36748",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 438423,
"published_at": "2023-07-01T06:15:09.433+00:00"
}