Skip to content
Heist/ feed
Back to feed
High

POST SMTP Mailer – Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress <= 2.8.7 - Unauthenticated Stored Cross-Site Scripting via device

Type: advisorySources: OSV

The POST SMTP Mailer – Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘device’ header in all versions up to, and including, 2.8.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2023-7027
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 03:50 UTC · Revision 1

Source evidence

POST SMTP Mailer – Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress <= 2.8.7 - Unauthenticated Stored Cross-Site Scripting via device

core-osv · Original source

Published 3 Jan 2024, 04:29 UTC

The POST SMTP Mailer – Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘device’ header in all versions up to, and including, 2.8.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

osv:CVE-2023-7027
Complete source record
{
  "id": "179b91e42c55606664ebfd7d6cecb51cd514443b64ee150e13017f7255c366c9",
  "url": "https://osv.dev/vulnerability/CVE-2023-7027",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "POST SMTP Mailer – Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress <= 2.8.7 - Unauthenticated Stored Cross-Site Scripting via device",
    "summary": "The POST SMTP Mailer – Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘device’ header in all versions up to, and including, 2.8.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
    "evidence": "osv:CVE-2023-7027",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2023-7027",
      "aliases": [
        "CVE-2023-7027"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/wpexpertsio/post-smtp",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "e3153922a35c9b2165c66ba5103abd279bb69f4d"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wpexperts:post_smtp:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.8.8"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "2.5.9-beta.1",
            "2.8.7",
            "2.8.5",
            "2.8.4",
            "2.7.0",
            "2.8.3",
            "2.7.2",
            "2.6.0",
            "2.5.9.4",
            "2.5.9.3",
            "2.5.8",
            "2.5.7",
            "2.5.6",
            "2.5.5",
            "2.5.4",
            "2.5.3",
            "2.5.2",
            "2.5.1",
            "2.5.0",
            "2.5-rc.3",
            "2.5-rc.2",
            "2.5-rc.1",
            "2.5-beta.1",
            "2.4.3",
            "2.4.2-beta.2",
            "2.4.2",
            "2.4.1",
            "2.4",
            "2.4-beta.1",
            "2.3.1",
            "2.3",
            "2.2.1",
            "2.2",
            "2.2-beta.2",
            "2.1.8",
            "2.1.7",
            "2.1.6",
            "2.1.4",
            "2.1.4-rc.2",
            "2.1.4-rc.1",
            "2.1.4-beta.1",
            "2.1.2",
            "2.1.2-rc.2",
            "2.1.2-rc.1",
            "2.1.2-beta-1",
            "2.1.1.1",
            "2.1.1",
            "2.1",
            "2.1-beta.1",
            "2.0.27",
            "2.0.26",
            "2.0.25-beta.1",
            "2.0.25",
            "2.0.24",
            "2.0.23",
            "2.0.22",
            "2.0.21",
            "2.0.20",
            "2.0.19",
            "2.0.18",
            "2.0.17",
            "2.0.16",
            "2.0.15",
            "2.0.14",
            "2.0.13",
            "2.0.12",
            "2.0.11",
            "2.0.10",
            "2.0.9",
            "2.0.8",
            "2.0.7",
            "2.0.6",
            "2.0.5",
            "2.0.4",
            "2.0.3",
            "2.0.2",
            "2.0.1",
            "v1.9.8",
            "v1.9.7",
            "v1.9.6",
            "v1.9.5",
            "v1.9.4",
            "v1.9.3",
            "v.1.9.2",
            "v.1.9.1",
            "v.1.9.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-7027.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:32.830266461Z",
      "provider": "osv",
      "references": [
        "https://plugins.trac.wordpress.org/browser/post-smtp/trunk/Postman/Mobile/includes/rest-api/v1/rest-api.php#L79",
        "https://plugins.trac.wordpress.org/browser/post-smtp/trunk/Postman/Mobile/mobile.php#L219",
        "https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3016126%40post-smtp%2Ftrunk&old=3012318%40post-smtp%2Ftrunk&sfp_email=&sfph_mail=",
        "https://www.wordfence.com/threat-intel/vulnerabilities/id/7e8911a3-ce0f-420c-bf2a-1c2929d01cef?source=cve",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/7xxx/CVE-2023-7027.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2023-7027"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "Wordfence",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "last_affected": "2.8.7"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/7xxx/CVE-2023-7027.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2023-7027",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 500112,
  "published_at": "2024-01-03T04:29:34.469+00:00"
}