Skip to content
Heist/ feed
Back to feed
High

The Apache Linkis JDBC EngineConn module has a RCE Vulnerability

Type: advisorySources: OSV

In Apache Linkis <=1.2.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures a JDBC EC with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.2.0 will be affected, We recommend users to update to 1.3.0.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-39944
Confirmed fixed CVEs
Not specified
Updated in this feed
2 Nov 2026, 21:16 UTC · Revision 1

Source evidence

The Apache Linkis JDBC EngineConn module has a RCE Vulnerability

core-osv · Original source

Published 26 Oct 2022, 00:00 UTC

In Apache Linkis <=1.2.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures a JDBC EC with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.2.0 will be affected, We recommend users to update to 1.3.0.

osv:CVE-2022-39944
Complete source record
{
  "id": "0ddde121d9488f5a371902de08d511b2d76abf35a533921334b9ede40367cfe9",
  "url": "https://osv.dev/vulnerability/CVE-2022-39944",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "The Apache Linkis JDBC EngineConn module has a RCE Vulnerability",
    "summary": "In Apache Linkis <=1.2.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures a JDBC EC with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.2.0 will be affected, We recommend users to update to 1.3.0.",
    "evidence": "osv:CVE-2022-39944",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2022-39944",
      "aliases": [
        "CVE-2022-39944",
        "GHSA-3f3w-gmqf-4hj3"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/linkis",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "last_affected": "70f71d11959d4523ba1932deecbf722c000341b9"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:linkis:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "last_affected": "1.2.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.2.0-rc1",
            "1.2.0",
            "1.0.2",
            "1.0.1",
            "1.0.0",
            "1.0.0-RC1",
            "0.11.0",
            "0.10.0",
            "0.9.4",
            "0.9.3",
            "0.9.2",
            "0.9.1",
            "0.8.0",
            "0.7.0",
            "0.6.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-39944.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:23.495662476Z",
      "provider": "osv",
      "references": [
        "https://lists.apache.org/thread/rxytj48q17304snonjtyt5lnlw64gccc",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39944.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-39944"
      ],
      "provider_metadata": {
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "Apache Linkis"
                  },
                  {
                    "last_affected": "1.2.0"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39944.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-39944",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 490149,
  "published_at": "2022-10-26T00:00:00+00:00"
}