protobuf — security advisory
A parsing issue similar to CVE-2022-3171, but with Message-Type Extensions in protobuf-java core and lite versions prior to 3.21.7, 3.20.3, 3.19.6 and 3.16.3 can lead to a denial of service attack. Inputs containing multiple instances of non-repeated embedded messages with repeated or unknown fields causes objects to be converted back-n-forth between mutable and immutable forms, resulting in potentially long garbage collection pauses. We recommend updating to the versions mentioned above.
- Products
- protobuf
- Affected versions
- Not specified
- Fixed versions
- 3.21.9-3
- CVEs
- CVE-2022-3510
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:58 UTC · Revision 1
Source evidence
A parsing issue similar to CVE-2022-3171, but with Message-Type Extensions in protobuf-java core and lite versions prior to 3.21.7, 3.20.3, 3.19.6 and 3.16.3 can lead to a denial of service attack. Inputs containing multiple instances of non-repeated embedded messages with repeated or unknown fields causes objects to be converted back-n-forth between mutable and immutable forms, resulting in potentially long garbage collection pauses. We recommend updating to the versions mentioned above.
osv:DEBIAN-CVE-2022-3510
protobuf
Fixed versions: 3.21.9-3
protobuf
Fixed versions: 3.21.9-3
protobuf
Fixed versions: 3.21.9-3
Complete source record
{
"id": "7b101b0064fcea9707278f15f2403482d8eda5e2b90dab4a4b49e77c08bbf9de",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-3510",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-3510",
"summary": "A parsing issue similar to CVE-2022-3171, but with Message-Type Extensions in protobuf-java core and lite versions prior to 3.21.7, 3.20.3, 3.19.6 and 3.16.3 can lead to a denial of service attack. Inputs containing multiple instances of non-repeated embedded messages with repeated or unknown fields causes objects to be converted back-n-forth between mutable and immutable forms, resulting in potentially long garbage collection pauses. We recommend updating to the versions mentioned above.",
"evidence": "osv:DEBIAN-CVE-2022-3510",
"products": [
{
"name": {
"value": "protobuf",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.21.9-3",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "protobuf",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.21.9-3",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "protobuf",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.21.9-3",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-3510",
"aliases": [
"DEBIAN-CVE-2022-3510"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.21.9-3"
}
]
}
],
"package": {
"name": "protobuf",
"purl": "pkg:deb/debian/protobuf?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-3510.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.21.9-3"
}
]
}
],
"package": {
"name": "protobuf",
"purl": "pkg:deb/debian/protobuf?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-3510.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.21.9-3"
}
]
}
],
"package": {
"name": "protobuf",
"purl": "pkg:deb/debian/protobuf?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-3510.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:39.745922587Z",
"provider": "osv",
"upstream": [
"CVE-2022-3510"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-3510"
]
},
"related_cves": [
{
"value": "CVE-2022-3510",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 323902,
"published_at": "2022-12-12T13:15:14.67+00:00"
}