UnratedFix available
policykit-1 — security advisory
Format string vulnerability in the grant helper (polkit-grant-helper.c) in PolicyKit 0.7 and earlier allows attackers to cause a denial of service (crash) and possibly execute arbitrary code via format strings in a password.
- Products
- policykit-1
- Affected versions
- Not specified
- Fixed versions
- 0.8-1
- CVEs
- CVE-2008-1658
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 22:32 UTC · Revision 1
Source evidence
Format string vulnerability in the grant helper (polkit-grant-helper.c) in PolicyKit 0.7 and earlier allows attackers to cause a denial of service (crash) and possibly execute arbitrary code via format strings in a password.
osv:DEBIAN-CVE-2008-1658
policykit-1
Fixed versions: 0.8-1
policykit-1
Fixed versions: 0.8-1
policykit-1
Fixed versions: 0.8-1
Complete source record
{
"id": "a6febba1b7c5153ccca95c34123ba6570be80b12617464952881aa661a07b68b",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2008-1658",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2008-1658",
"summary": "Format string vulnerability in the grant helper (polkit-grant-helper.c) in PolicyKit 0.7 and earlier allows attackers to cause a denial of service (crash) and possibly execute arbitrary code via format strings in a password.",
"evidence": "osv:DEBIAN-CVE-2008-1658",
"products": [
{
"name": {
"value": "policykit-1",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.8-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "policykit-1",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.8-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "policykit-1",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.8-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2008-1658",
"aliases": [
"DEBIAN-CVE-2008-1658"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.8-1"
}
]
}
],
"package": {
"name": "policykit-1",
"purl": "pkg:deb/debian/policykit-1?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2008-1658.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.8-1"
}
]
}
],
"package": {
"name": "policykit-1",
"purl": "pkg:deb/debian/policykit-1?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2008-1658.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.8-1"
}
]
}
],
"package": {
"name": "policykit-1",
"purl": "pkg:deb/debian/policykit-1?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2008-1658.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
}
],
"modified": "2026-10-23T17:47:23.317720765Z",
"provider": "osv",
"upstream": [
"CVE-2008-1658"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2008-1658"
]
},
"related_cves": [
{
"value": "CVE-2008-1658",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 416663,
"published_at": "2008-04-11T10:05:00+00:00"
}