lucene-solr — security advisory
Incorrect Permission Assignment for Critical Resource, Improper Control of Dynamically-Managed Code Resources vulnerability in Apache Solr. This issue affects Apache Solr: from 8.10.0 through 8.11.2, from 9.0.0 before 9.3.0. The Schema Designer was introduced to allow users to more easily configure and test new Schemas and configSets. However, when the feature was created, the "trust" (authentication) of these configSets was not considered. External library loading is only available to configSets that are "trusted" (created by authenticated users), thus non-authenticated users are unable to perform Remote Code Execution. Since the Schema Designer loaded configSets without taking their "trust" into account, configSets that were created by unauthenticated users were allowed to load external libraries when used in the Schema Designer. Users are recommended to upgrade to version 9.3.0, which fixes the issue.
- Products
- lucene-solr
- Affected versions
- Not specified
- Fixed versions
- 3.6.2+dfsg-23
- CVEs
- CVE-2023-50292
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 16:06 UTC · Revision 1
Source evidence
Incorrect Permission Assignment for Critical Resource, Improper Control of Dynamically-Managed Code Resources vulnerability in Apache Solr. This issue affects Apache Solr: from 8.10.0 through 8.11.2, from 9.0.0 before 9.3.0. The Schema Designer was introduced to allow users to more easily configure and test new Schemas and configSets. However, when the feature was created, the "trust" (authentication) of these configSets was not considered. External library loading is only available to configSets that are "trusted" (created by authenticated users), thus non-authenticated users are unable to perform Remote Code Execution. Since the Schema Designer loaded configSets without taking their "trust" into account, configSets that were created by unauthenticated users were allowed to load external libraries when used in the Schema Designer. Users are recommended to upgrade to version 9.3.0, which fixes the issue.
osv:DEBIAN-CVE-2023-50292
lucene-solr
Fixed versions: 3.6.2+dfsg-23
lucene-solr
Fixed versions: 3.6.2+dfsg-23
lucene-solr
Fixed versions: 3.6.2+dfsg-23
Complete source record
{
"id": "a4494b3c1c49d944d08fb880419ec7307bcd0f89beeb970573d0cb504783a17b",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2023-50292",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2023-50292",
"summary": "Incorrect Permission Assignment for Critical Resource, Improper Control of Dynamically-Managed Code Resources vulnerability in Apache Solr. This issue affects Apache Solr: from 8.10.0 through 8.11.2, from 9.0.0 before 9.3.0. The Schema Designer was introduced to allow users to more easily configure and test new Schemas and configSets. However, when the feature was created, the \"trust\" (authentication) of these configSets was not considered. External library loading is only available to configSets that are \"trusted\" (created by authenticated users), thus non-authenticated users are unable to perform Remote Code Execution. Since the Schema Designer loaded configSets without taking their \"trust\" into account, configSets that were created by unauthenticated users were allowed to load external libraries when used in the Schema Designer. Users are recommended to upgrade to version 9.3.0, which fixes the issue.",
"evidence": "osv:DEBIAN-CVE-2023-50292",
"products": [
{
"name": {
"value": "lucene-solr",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.6.2+dfsg-23",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "lucene-solr",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.6.2+dfsg-23",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "lucene-solr",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.6.2+dfsg-23",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2023-50292",
"aliases": [
"DEBIAN-CVE-2023-50292"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.6.2+dfsg-23"
}
]
}
],
"package": {
"name": "lucene-solr",
"purl": "pkg:deb/debian/lucene-solr?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-50292.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.6.2+dfsg-23"
}
]
}
],
"package": {
"name": "lucene-solr",
"purl": "pkg:deb/debian/lucene-solr?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-50292.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.6.2+dfsg-23"
}
]
}
],
"package": {
"name": "lucene-solr",
"purl": "pkg:deb/debian/lucene-solr?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2023-50292.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T18:02:42.487960776Z",
"provider": "osv",
"upstream": [
"CVE-2023-50292"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2023-50292"
]
},
"related_cves": [
{
"value": "CVE-2023-50292",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 456655,
"published_at": "2024-02-09T18:15:08.363+00:00"
}