Critical
Security advisory
mongo-express before 0.54.0 is vulnerable to Remote Code Execution via endpoints that uses the `toBSON` method. A misuse of the `vm` dependency to perform `exec` commands in a non-safe environment.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-10758
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 04:17 UTC · Revision 1
Source evidence
mongo-express before 0.54.0 is vulnerable to Remote Code Execution via endpoints that uses the `toBSON` method. A misuse of the `vm` dependency to perform `exec` commands in a non-safe environment.
osv:CVE-2019-10758
Complete source record
{
"id": "17c50aaf987fa8691116f5f9eae1bcf2fd63e8b315e50581ce8be36666c29f33",
"url": "https://osv.dev/vulnerability/CVE-2019-10758",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-10758",
"summary": "mongo-express before 0.54.0 is vulnerable to Remote Code Execution via endpoints that uses the `toBSON` method. A misuse of the `vm` dependency to perform `exec` commands in a non-safe environment.",
"evidence": "osv:CVE-2019-10758",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2019-10758",
"aliases": [
"CVE-2019-10758",
"GHSA-h47j-hc6x-h3qq",
"SNYK-JS-MONGOEXPRESS-473215"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/mongo-express/mongo-express",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "7d365141deadbd38fa961cd835ce68eab5731494"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:mongo-express_project:mongo-express:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.54.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v0.53.0",
"v0.52.2",
"v0.52.1",
"v0.52.0",
"v0.51.2",
"v0.51.1",
"v0.51.0",
"v0.50.0",
"v0.49.0",
"v0.48.1",
"v0.48.0",
"v0.47.0",
"v0.46.1",
"v0.46.0",
"v0.45.0",
"v0.44.0",
"v0.43.1",
"v0.43.0",
"v0.42.3",
"v0.42.2",
"v0.42.1",
"v0.42.0",
"v0.41.0",
"v0.40.0",
"v0.39.2",
"v0.39.1",
"v0.39.0",
"v0.38.0",
"v0.37.2",
"v0.37.1",
"v0.37.0",
"v0.35.0",
"v0.34.0",
"v0.33.0",
"v0.32.0",
"0.29.10",
"v0.27.4",
"v0.17.5",
"v0.17.4",
"v0.17.3",
"v0.17.2",
"v0.17.1",
"v0.17.0",
"v0.16.1",
"v0.16.0",
"v0.15.0",
"v0.14.1",
"v0.14.0",
"v0.13.0",
"v0.12.0",
"v0.11.3",
"v0.11.2",
"v0.11.1",
"v0.11.0",
"v0.10.0",
"v0.9.0",
"v0.8.1",
"v0.8.0",
"v0.7.1",
"v0.7.0",
"v0.6.0",
"v0.5.0",
"v0.4.0",
"v0.3.4",
"v0.3.3",
"v0.3.2",
"v0.3.1",
"v0.3.0",
"v0.2.3",
"v0.2.2",
"v0.2.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-10758.json"
}
}
],
"modified": "2026-10-24T10:30:16.676719303Z",
"provider": "osv",
"references": [
"https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2019-10758",
"https://snyk.io/vuln/SNYK-JS-MONGOEXPRESS-473215"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2019-10758",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 429393,
"published_at": "2019-12-24T22:15:11.183+00:00"
}