Skip to content
Heist/ feed
Back to feed
Critical

Security advisory

Type: advisorySources: OSVCVE: CVE-2021-4259

A vulnerability was found in phpRedisAdmin up to 1.16.1. It has been classified as problematic. This affects the function authHttpDigest of the file includes/login.inc.php. The manipulation of the argument response leads to use of wrong operator in string comparison. Upgrading to version 1.16.2 is able to address this issue. The name of the patch is 31aa7661e6db6f4dffbf9a635817832a0a11c7d9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216267.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2021-4259
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 11:58 UTC · Revision 1

Source evidence

CVE-2021-4259

core-osv · Original source

Published 19 Dec 2022, 14:15 UTC

A vulnerability was found in phpRedisAdmin up to 1.16.1. It has been classified as problematic. This affects the function authHttpDigest of the file includes/login.inc.php. The manipulation of the argument response leads to use of wrong operator in string comparison. Upgrading to version 1.16.2 is able to address this issue. The name of the patch is 31aa7661e6db6f4dffbf9a635817832a0a11c7d9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216267.

osv:CVE-2021-4259
Complete source record
{
  "id": "8eb4b8706e0425ed657910d589e8a5fdc93a64ce3e2a7e9b1fd8971a08a03139",
  "url": "https://osv.dev/vulnerability/CVE-2021-4259",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2021-4259",
    "summary": "A vulnerability was found in phpRedisAdmin up to 1.16.1. It has been classified as problematic. This affects the function authHttpDigest of the file includes/login.inc.php. The manipulation of the argument response leads to use of wrong operator in string comparison. Upgrading to version 1.16.2 is able to address this issue. The name of the patch is 31aa7661e6db6f4dffbf9a635817832a0a11c7d9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216267.",
    "evidence": "osv:CVE-2021-4259",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2021-4259",
      "aliases": [
        "CVE-2021-4259"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/erikdubbelboer/phpredisadmin",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "33d3d99ccbb553bb12d2b10c4e45abafd55bcd3c"
                },
                {
                  "fixed": "31aa7661e6db6f4dffbf9a635817832a0a11c7d9"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:phpredisadmin_project:phpredisadmin:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.16.2"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "31aa7661e6db6f4dffbf9a635817832a0a11c7d9"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "33d3d99ccbb553bb12d2b10c4e45abafd55bcd3c"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v1.16.2"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v1.16.1",
            "v1.16.0",
            "v1.15.0",
            "v1.14.1",
            "v1.14.0",
            "v1.13.2",
            "v1.13.1",
            "v1.13.0",
            "v1.12.0",
            "v1.11.5",
            "v1.11.4",
            "v1.11.3",
            "v1.11.2",
            "v1.11.1",
            "v1.11.0",
            "v1.10.2",
            "v1.10.1",
            "v1.10.0",
            "v1.9.0",
            "v1.8.0",
            "v1.7.0",
            "v1.6.0",
            "v1.5.0",
            "1.4.2",
            "v1.4.1",
            "v1.4.0",
            "v1.3.0",
            "v1.2.1",
            "v1.2.0",
            "v1.1.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-4259.json"
          }
        }
      ],
      "modified": "2026-10-20T10:55:00.774709473Z",
      "provider": "osv",
      "references": [
        "https://github.com/erikdubbelboer/phpRedisAdmin/releases/tag/v1.16.2",
        "https://vuldb.com/?id.216267",
        "https://github.com/erikdubbelboer/phpRedisAdmin/commit/31aa7661e6db6f4dffbf9a635817832a0a11c7d9"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2021-4259",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 386676,
  "published_at": "2022-12-19T14:15:10.497+00:00"
}