Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2021-24892

Insecure Direct Object Reference in edit function of Advanced Forms (Free & Pro) before 1.6.9 allows authenticated remote attacker to change arbitrary user's email address and request for reset password, which could lead to take over of WordPress's administrator account. To exploit this vulnerability, an attacker must register to obtain a valid WordPress's user and use such user to authenticate with WordPress in order to exploit the vulnerable edit function.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2021-24892
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 11:41 UTC · Revision 1

Source evidence

CVE-2021-24892

core-osv · Original source

Published 23 Nov 2021, 20:15 UTC

Insecure Direct Object Reference in edit function of Advanced Forms (Free & Pro) before 1.6.9 allows authenticated remote attacker to change arbitrary user's email address and request for reset password, which could lead to take over of WordPress's administrator account. To exploit this vulnerability, an attacker must register to obtain a valid WordPress's user and use such user to authenticate with WordPress in order to exploit the vulnerable edit function.

osv:CVE-2021-24892
Complete source record
{
  "id": "64269280c4c6d886fe48257dfbb5134cb25d320adbf45f40f64dae7ac83a7369",
  "url": "https://osv.dev/vulnerability/CVE-2021-24892",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2021-24892",
    "summary": "Insecure Direct Object Reference in edit function of Advanced Forms (Free & Pro) before 1.6.9 allows authenticated remote attacker to change arbitrary user's email address and request for reset password, which could lead to take over of WordPress's administrator account. To exploit this vulnerability, an attacker must register to obtain a valid WordPress's user and use such user to authenticate with WordPress in order to exploit the vulnerable edit function.",
    "evidence": "osv:CVE-2021-24892",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2021-24892",
      "aliases": [
        "CVE-2021-24892"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/advancedforms/advanced-forms",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2ce3ab6985c3a909eefb01c562995bc6a994d3a2"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "fixed": "2ce3ab6985c3a909eefb01c562995bc6a994d3a2"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-24892.json"
          }
        }
      ],
      "modified": "2026-10-20T10:54:33.434194547Z",
      "provider": "osv",
      "references": [
        "https://github.com/advancedforms/advanced-forms/commit/2ce3ab6985c3a909eefb01c562995bc6a994d3a2",
        "https://wpscan.com/vulnerability/364b0843-a990-4204-848a-60c928cc5bc0"
      ],
      "provider_metadata": {
        "unresolved_ranges": [
          {
            "cpes": [
              "cpe:2.3:a:advanced_forms_project:advanced_forms:*:*:*:*:free:wordpress:*:*",
              "cpe:2.3:a:advanced_forms_project:advanced_forms:*:*:*:*:pro:wordpress:*:*"
            ],
            "vendor_product": "advanced_forms_project:advanced_forms",
            "extracted_events": [
              {
                "range": [
                  {
                    "fixed": "1.6.9"
                  },
                  {
                    "fixed": "1.6.9"
                  }
                ],
                "source": "CPE_RANGE"
              }
            ]
          },
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "fixed": "1.6.9"
                  }
                ],
                "source": "DESCRIPTION"
              }
            ]
          }
        ]
      }
    },
    "related_cves": [
      {
        "value": "CVE-2021-24892",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 385562,
  "published_at": "2021-11-23T20:15:10.463+00:00"
}