Sharp user-provided input can be evaluated in a SharpShowTextField with Vue template syntax
Sharp is a content management framework built for Laravel as a package. Prior to 9.11.1, a Cross-Site Scripting (XSS) vulnerability was discovered in code16/sharp when rendering content using the SharpShowTextField component. In affected versions, expressions wrapped in {{ & }} were evaluated by Vue. This allowed attackers to inject arbitrary JavaScript or HTML that executes in the browser when the field is displayed. The issue has been fixed in v9.11.1 .
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-62798
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 02:32 UTC · Revision 1
Source evidence
Sharp user-provided input can be evaluated in a SharpShowTextField with Vue template syntax
core-osv · Original sourcePublished 28 Oct 2025, 20:58 UTC
Sharp is a content management framework built for Laravel as a package. Prior to 9.11.1, a Cross-Site Scripting (XSS) vulnerability was discovered in code16/sharp when rendering content using the SharpShowTextField component. In affected versions, expressions wrapped in {{ & }} were evaluated by Vue. This allowed attackers to inject arbitrary JavaScript or HTML that executes in the browser when the field is displayed. The issue has been fixed in v9.11.1 .
osv:CVE-2025-62798
Complete source record
{
"id": "7c4cd3a5849acee055d0aeac4eab65fd116502403af9d5cd991ad3125229dbaf",
"url": "https://osv.dev/vulnerability/CVE-2025-62798",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Sharp user-provided input can be evaluated in a SharpShowTextField with Vue template syntax",
"summary": "Sharp is a content management framework built for Laravel as a package. Prior to 9.11.1, a Cross-Site Scripting (XSS) vulnerability was discovered in code16/sharp when rendering content using the SharpShowTextField component. In affected versions, expressions wrapped in {{ & }} were evaluated by Vue. This allowed attackers to inject arbitrary JavaScript or HTML that executes in the browser when the field is displayed. The issue has been fixed in v9.11.1 .",
"evidence": "osv:CVE-2025-62798",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-62798",
"aliases": [
"CVE-2025-62798",
"GHSA-9f58-4465-23c7"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/code16/sharp",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "99f71efe3e8510009fa2e120dfeba7691e8cfa2b"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "9.11.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "99f71efe3e8510009fa2e120dfeba7691e8cfa2b"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v9.11.1"
},
{
"range": [
{
"introduced": "0"
},
{
"fixed": "9.11.1"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"versions": [
"v9.11.0",
"v9.10.2",
"v9.10.1",
"v9.10.0",
"v9.9.0",
"v9.8.1",
"v9.7.3",
"v9.7.2",
"v9.7.0",
"v9.6.6",
"v9.6.5",
"v9.6.4",
"v9.6.3",
"v9.6.2",
"v9.5.2",
"v9.5.1",
"v9.5.0",
"v9.4.1",
"v9.4.0",
"v9.3.7",
"v9.3.4",
"v9.3.1",
"v9.2.8",
"v9.2.7",
"v9.2.5",
"v9.2.4",
"v9.2.3",
"v9.2.2",
"v9.2.0",
"v9.1.0",
"v9.0.5",
"v9.0.3",
"v8.6.1",
"v8.6.0",
"v8.5.0",
"v8.4.4",
"v8.4.3",
"v8.4.2",
"v8.4.1",
"v8.4.0",
"v8.3.7",
"v8.3.6",
"v8.3.4",
"v8.3.5",
"v8.3.1",
"v8.2.1",
"v8.2.0",
"v8.1.2",
"v7.29.6",
"v8.1.0",
"v8.0.7",
"v8.0.6",
"v8.0.3",
"v8.0.2",
"v8.0.1",
"v8.0.0",
"v7.29.5",
"v7.29.4",
"v7.29.3",
"v7.29.2",
"v7.29.1",
"v7.28.0",
"v7.27.1",
"v7.27.0",
"v7.26.2",
"v7.26.1",
"v7.26.0",
"v7.25.2",
"v7.25.1",
"v7.25.0",
"v7.24.0",
"v7.23.2",
"v7.23.0",
"v7.22.0",
"v7.21.0",
"v7.20.0",
"v7.19.1",
"v7.19.0",
"v7.17.3",
"v7.17.2",
"v7.17.1",
"v7.17.0",
"v7.16.0",
"v7.14.0",
"v7.13.0",
"v7.12.0",
"v7.11.0",
"v7.10.0",
"v7.9.0",
"v7.8.0",
"7.7.2",
"v7.7.1",
"v7.7.0",
"v7.6.0",
"v7.5.2",
"v7.5.1",
"v7.5.0",
"v7.4.0",
"v7.3.0",
"v7.2.5",
"v7.2.4",
"v7.2.3",
"v7.2.2",
"v7.2.1",
"v7.2.0",
"v7.1.0",
"v7.0.2",
"v7.0.1",
"v7.0.0",
"v6.5.4",
"v6.5.3",
"v6.5.2",
"v6.5.1",
"v6.5.0",
"v6.4.1",
"v6.3.3",
"v6.4.0",
"v6.3.2",
"v6.3.1",
"v6.3.0",
"v5.4.5",
"v6.2.0",
"v6.1.5",
"v6.1.4",
"v6.1.3",
"v6.1.2",
"v6.1.0",
"v6.0.1",
"v6.0.0",
"v5.4.4",
"v5.4.3",
"v5.4.2",
"v5.4.1",
"v5.4.0",
"v5.3.3",
"v5.3.2",
"v5.3.1",
"v5.3.0",
"v5.1.2",
"v5.1.1",
"v5.1.0",
"v5.0.0",
"v4.2.6",
"v4.2.5",
"v4.2.4",
"v4.2.3",
"v4.2.0",
"v4.1.16",
"v4.1.15",
"v4.1.13",
"v4.1.11",
"v4.1.8",
"v4.1.7",
"v4.1.6",
"v4.1.5",
"v4.1.4",
"v4.1.3",
"v4.1.2",
"v4.1.1",
"v4.1.0",
"v4.0.20",
"v4.0.19",
"v4.0.14",
"v4.0.13",
"v4.0.12",
"v4.0.11",
"v4.0.8",
"v4.0.7",
"v4.0.5",
"v4.0.0",
"v4.0-BETA6",
"v4.0-BETA3"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-62798.json"
}
}
],
"modified": "2026-10-28T02:30:25.571661436Z",
"provider": "osv",
"references": [
"https://github.com/code16/sharp/releases/tag/v9.11.1",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/62xxx/CVE-2025-62798.json",
"https://github.com/code16/sharp/security/advisories/GHSA-9f58-4465-23c7",
"https://nvd.nist.gov/vuln/detail/CVE-2025-62798",
"https://github.com/code16/sharp/pull/654"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/62xxx/CVE-2025-62798.json"
}
},
"related_cves": [
{
"value": "CVE-2025-62798",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 491907,
"published_at": "2025-10-28T20:58:21.793+00:00"
}