High
Security advisory
VSCodeVim before 1.19.0 allows attackers to execute arbitrary code via a crafted workspace configuration.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-28832
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:44 UTC · Revision 1
Source evidence
VSCodeVim before 1.19.0 allows attackers to execute arbitrary code via a crafted workspace configuration.
osv:CVE-2021-28832
Complete source record
{
"id": "04945f1e7996d92a468a8869cc8926eb1c93a75b28a82fe0c10044b3200c501b",
"url": "https://osv.dev/vulnerability/CVE-2021-28832",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-28832",
"summary": "VSCodeVim before 1.19.0 allows attackers to execute arbitrary code via a crafted workspace configuration.",
"evidence": "osv:CVE-2021-28832",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2021-28832",
"aliases": [
"CVE-2021-28832"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/vscodevim/vim",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "bacae1762ccbb7838a9a6db0f114fd7688689e9b"
},
{
"fixed": "939df0e7fd55a9840dbd4fb3c907315e2a5ef446"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:vim_project:vim:*:*:*:*:*:visual_studio_code:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.19.0"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "939df0e7fd55a9840dbd4fb3c907315e2a5ef446"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v1.18.9",
"v1.18.8",
"v1.18.7",
"v1.18.5",
"v1.18.4",
"v1.18.3",
"v1.18.2",
"v1.18.0",
"v1.17.1",
"v1.17.0",
"beta",
"v1.16.0",
"v1.15.0",
"v1.14.5",
"v1.14.4",
"v1.14.3",
"v1.14.2",
"v1.14.1",
"v1.14.0",
"v1.13.1",
"v1.13.0",
"v1.12.4",
"v1.12.3",
"v1.12.0",
"v1.10.2",
"v1.10.1",
"v1.10.0",
"v1.9.0",
"v1.8.2",
"v1.8.1",
"v1.8.0",
"v1.7.1",
"v1.7.0",
"v1.4.0",
"v1.3.0",
"v1.2.0",
"v1.1.0",
"v1.0.8",
"v1.0.5",
"v1.0.2",
"v0.17.2",
"v0.16.13",
"v0.16.11",
"v0.16.9",
"v0.16.8",
"v0.16.7",
"v0.16.5",
"v0.16.4",
"v0.16.3",
"v0.16.2",
"v0.16.0",
"v0.15.7",
"v0.15.6",
"v0.15.5",
"v0.15.4",
"v0.15.3",
"v0.15.2",
"v0.15.0",
"v0.14.2",
"v0.14.1",
"v0.14.0",
"v0.13.1",
"v0.13.0",
"v0.12.0",
"v0.11.6",
"v0.11.5",
"v0.11.4",
"v0.11.3",
"v0.11.2",
"v0.11.1",
"v0.11.0",
"v0.10.13",
"v0.10.12",
"v0.10.11",
"v0.10.10",
"v0.10.9",
"v0.10.7",
"v0.10.6",
"v0.10.5",
"v0.10.3",
"v0.10.4",
"v0.10.2",
"v0.10.1",
"v0.10.0",
"v0.9.0",
"v0.8.7",
"v0.6.18",
"v0.6.17",
"v0.6.16",
"0.6.15",
"0.6.14",
"v0.6.13",
"0.6.12",
"v0.6.11",
"v0.6.10",
"v0.6.9",
"v0.6.8",
"v0.6.7",
"v0.6.6",
"v0.6.5",
"v0.6.4",
"v0.6.3",
"v0.6.0",
"v0.5.3",
"v0.5.1",
"v0.5.0",
"0.4.5",
"v0.4.5",
"v0.4.2",
"v0.4.1",
"v0.4.0",
"0.3.3",
"v0.3.8",
"0.3.7",
"0.3.6",
"0.3.5",
"0.3.4",
"0.3.2",
"v0.3.1",
"v0.2.0",
"v0.1.11",
"v0.1.10",
"v0.1.9",
"v0.1.8",
"v0.1.7",
"v0.1.6",
"v0.1.5",
"0.1.5",
"v0.1.4",
"v0.1.3",
"v0.1.2",
"v0.1.1",
"v0.1",
"v0.0.28",
"v0.0.27",
"v0.0.26",
"0.0.26",
"v0.0.25",
"0.0.25",
"v0.0.24",
"0.0.24",
"v0.0.23",
"0.0.23",
"v0.0.22",
"v0.0.20",
"v0.0.19",
"v0.0.18",
"v0.0.17",
"v0.0.16",
"v0.0.15",
"v0.0.14",
"v0.0.13",
"v0.0.12",
"v0.0.11",
"v0.0.10",
"v0.0.9",
"0.0.9",
"v0.0.8",
"v0.0.7",
"v0.0.6",
"v0.0.5",
"v0.0.3",
"v0.0.2",
"v0.0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-28832.json"
}
}
],
"modified": "2026-10-20T10:54:38.553627271Z",
"provider": "osv",
"references": [
"https://marketplace.visualstudio.com/items?itemName=vscodevim.vim",
"https://vuln.ryotak.me/advisories/9",
"https://github.com/VSCodeVim/Vim/commit/939df0e7fd55a9840dbd4fb3c907315e2a5ef446"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-28832",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 385788,
"published_at": "2021-04-05T07:15:13.227+00:00"
}